sys-devel/clang-runtime: Bump to 9.0.1_rc1
authorMichał Górny <mgorny@gentoo.org>
Sat, 23 Nov 2019 07:49:05 +0000 (08:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 23 Nov 2019 07:55:27 +0000 (08:55 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang-runtime/clang-runtime-9.0.1_rc1.ebuild [new file with mode: 0644]

diff --git a/sys-devel/clang-runtime/clang-runtime-9.0.1_rc1.ebuild b/sys-devel/clang-runtime/clang-runtime-9.0.1_rc1.ebuild
new file mode 100644 (file)
index 0000000..806c398
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+       compiler-rt? (
+               ~sys-libs/compiler-rt-${PV}:${SLOT}
+               sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+       )
+       libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+       openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"