dev-games/openscenegraph: [QA] Remove media-libs/jasper dep
authorDavid Seifert <soap@gentoo.org>
Wed, 28 Aug 2019 08:18:34 +0000 (10:18 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 28 Aug 2019 08:18:34 +0000 (10:18 +0200)
Bug: https://bugs.gentoo.org/689784
Closes: https://github.com/gentoo/gentoo/pull/12440
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: David Seifert <soap@gentoo.org>
dev-games/openscenegraph/openscenegraph-3.5.5.ebuild
dev-games/openscenegraph/openscenegraph-3.6.3.ebuild

index 7b066c0abf2c6d325a81d55b7ddc87410ce020e7..29582ffe909813adf7c3286e43c186bf85b6a946 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -17,7 +17,7 @@ LICENSE="wxWinLL-3 LGPL-2.1"
 SLOT="0/145" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
 KEYWORDS="amd64 ~hppa ~ia64 ppc ppc64 x86"
 IUSE="asio curl debug doc examples ffmpeg fltk fox gdal gif glut gstreamer gtk jpeg
-jpeg2k las libav lua openexr openinventor osgapps pdf png sdl sdl2 svg tiff
+las libav lua openexr openinventor osgapps pdf png sdl sdl2 svg tiff
 truetype vnc wxwidgets xine xrandr zlib"
 
 REQUIRED_USE="sdl2? ( sdl )"
@@ -49,7 +49,6 @@ RDEPEND="
                media-libs/gst-plugins-base:1.0
        )
        jpeg? ( virtual/jpeg:0 )
-       jpeg2k? ( media-libs/jasper:= )
        las? ( >=sci-geosciences/liblas-1.8.0 )
        lua? ( >=dev-lang/lua-5.1.5:* )
        openexr? (
@@ -112,7 +111,7 @@ src_configure() {
                -DWITH_GLIB=$(usex gstreamer)
                -DWITH_GtkGl=$(usex gtk)
                -DWITH_JPEG=$(usex jpeg)
-               -DWITH_Jasper=$(usex jpeg2k)
+               -DWITH_Jasper=OFF
                -DWITH_LIBLAS=$(usex las)
                -DWITH_Lua=$(usex lua)
                -DWITH_OpenEXR=$(usex openexr)
index b1bbf9578d9a38f5f876357525f7fa4b2dbf965b..995535e2ff3ccda636c6b5e3b71e2749fd8b4669 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -16,7 +16,7 @@ LICENSE="wxWinLL-3 LGPL-2.1"
 SLOT="0/158" # NOTE: CHECK WHEN BUMPING! Subslot is SOVERSION
 KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
 IUSE="asio curl debug doc egl examples ffmpeg fltk fox gdal gif glut gstreamer gtk jpeg
-jpeg2k las libav lua openexr openinventor osgapps pdf png sdl sdl2 svg tiff
+las libav lua openexr openinventor osgapps pdf png sdl sdl2 svg tiff
 truetype vnc wxwidgets xrandr zlib"
 
 REQUIRED_USE="sdl2? ( sdl )"
@@ -49,7 +49,6 @@ RDEPEND="
                media-libs/gst-plugins-base:1.0
        )
        jpeg? ( virtual/jpeg:0 )
-       jpeg2k? ( media-libs/jasper:= )
        las? ( >=sci-geosciences/liblas-1.8.0 )
        lua? ( >=dev-lang/lua-5.1.5:* )
        openexr? (
@@ -114,7 +113,7 @@ src_configure() {
                $(cmake-utils_use_find_package gstreamer GStreamer)
                $(cmake-utils_use_find_package gtk GtkGl)
                $(cmake-utils_use_find_package jpeg JPEG)
-               $(cmake-utils_use_find_package jpeg2k Jasper)
+               -DCMAKE_DISABLE_FIND_PACKAGE_Jasper=ON
                $(cmake-utils_use_find_package las LIBLAS)
                $(cmake-utils_use_find_package lua Lua51)
                -DCMAKE_DISABLE_FIND_PACKAGE_Lua52=ON