dev-util/clazy: Pin to <sys-devel/clang-10
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 22 Mar 2020 19:15:40 +0000 (20:15 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 22 Mar 2020 20:40:43 +0000 (21:40 +0100)
Bug: https://bugs.gentoo.org/711642
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-util/clazy/clazy-1.5-r1.ebuild

index d3f38a652bb61daf124e1fe067f47ccfbf429209..47f5433d9f01ac8f3066aabc39e6eaf0ea44f565 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -15,7 +15,7 @@ KEYWORDS="~amd64"
 IUSE=""
 
 RDEPEND="
-       sys-devel/clang:=
+       <sys-devel/clang-10:=
        >=sys-devel/llvm-3.8:=
 "
 DEPEND="${RDEPEND}"
@@ -37,7 +37,7 @@ src_configure() {
        # clang pulls in the equivalent llvm version, but not vice versa.
        # so, we must find llvm based on the installed clang version.
        # bug #681568
-       local clang_version=$(best_version sys-devel/clang)
+       local clang_version=$(best_version "<sys-devel/clang-10")
        export LLVM_ROOT="/usr/lib/llvm/$(ver_cut 1 ${clang_version##sys-devel/clang-})"
        cmake_src_configure
 }