dev-python/docker-py: Version bump to 3.3.0
authorManuel Rüger <mrueg@gentoo.org>
Sat, 26 May 2018 01:18:04 +0000 (03:18 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Sat, 26 May 2018 01:18:04 +0000 (03:18 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/docker-py/Manifest
dev-python/docker-py/docker-py-3.3.0.ebuild [new file with mode: 0644]

index 7b031d3b0aaf09e818f34d909a7a01ec85173bb5..ba0d97550a10b57652d0f1ec0724e2da5d191a7d 100644 (file)
@@ -3,3 +3,4 @@ DIST docker-py-2.7.0.tar.gz 196369 BLAKE2B dd181dbf32f5afda06e748cb49f15d5fc6ff4
 DIST docker-py-3.1.4.tar.gz 202064 BLAKE2B 6ee3672cd1f62cd570d3939805465698879d747215b8424bc4edd79253c5bc25d193582dbfa6aa423f9b183d477486d6347f65ac7245d601d3f1fe2a1fd124ed SHA512 78081010ce4027156d3b4ebafee6023f387ee8e7ee4d77ee671a16a3fcb646fca91c5c36cfbaf94157f8a524a3e1a09b9cbfabf304e278a3c1e0132df5d13d13
 DIST docker-py-3.2.0.tar.gz 205546 BLAKE2B 0784408a0373721e30cc101bf9e20e93af4721ace3841721b851efa49874163a1684239db6a56b7e91e83ad77eb4290dde61f53d70d6656853cedaff95da90b2 SHA512 fa36b65a047aec6dbec07b2ee5ac895b333acc804e372b5b3ccae587045fa03613f4083c66cd6289e188fd78c6f7012c4252e9bbf9f30a980fb94f32efba03b7
 DIST docker-py-3.2.1.tar.gz 205815 BLAKE2B fc9b23f57f64e3d25a922b896619f3d03780d446f03adb987c6a203df2c41fbc03b202cc8dac30392158dd0da4d600372b6af284d785179c0cf58f7048735da3 SHA512 c66f960bd507d8c4ed99e56480c24d11b13cf49420eee2f0934cede7516a8a9b984e5e0540a1d82d830768d3a5f0218dddd61255d55e7bd1b984072cd6e48a44
+DIST docker-py-3.3.0.tar.gz 206523 BLAKE2B dd5b1edda8b4c31c3febcedf8352262f090c6232419a0751181c1e765220905b93b50f26091123c31b7193aeb5d94e30f1ba49d114d1c2006a2c60ebaca80865 SHA512 ed2dedd57df344ab576053ac6d458808c67ce5aeeacddb1729ea5ebd0fb741e8f08cf9ed472e28d40eaba3a45f6c26727bff0ab7ece832bc3238f441ed149c05
diff --git a/dev-python/docker-py/docker-py-3.3.0.ebuild b/dev-python/docker-py/docker-py-3.3.0.ebuild
new file mode 100644 (file)
index 0000000..8ce9ced
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+       >=dev-python/docker-pycreds-0.2.3[${PYTHON_USEDEP}]
+       !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+               dev-python/pytest-runner[${PYTHON_USEDEP}]
+               >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+       )
+       doc? (
+               dev-python/recommonmark[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+       )
+"
+
+python_compile_all() {
+       if use doc; then
+               sphinx-build docs html || die "docs failed to build"
+               HTML_DOCS=( html/. )
+       fi
+}
+
+python_test() {
+       py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}