media-sound/justeport: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 11:03:25 +0000 (12:03 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 11:24:40 +0000 (12:24 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-sound/justeport/justeport-0.2.ebuild

index 2091e8017f7fedfa2478d9d8821f2915caa4770f..9ae64884305705f36813a7350c35734bd9eade40 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit mono multilib
 
@@ -11,7 +11,7 @@ DESCRIPTION="Stream audio to your AirPort Express"
 HOMEPAGE="http://nanocrew.net/software/justeport/"
 SRC_URI="http://nanocrew.net/sw/justeport/${MY_P}.tar.gz"
 
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
@@ -21,20 +21,10 @@ RDEPEND="${DEPEND}"
 
 S=${WORKDIR}/${MY_P}
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       cp "${FILESDIR}"/wrapper-script .
-       sed -i -e "s:LIBDIR:$(get_libdir):" wrapper-script || die "sed failed."
-}
-
-src_compile() {
-       emake || die "emake failed."
-}
-
 src_install() {
        insinto /usr/$(get_libdir)/justeport
-       doins *.exe || die "doins failed."
-       newbin wrapper-script justeport || die "newbin failed."
+       doins *.exe
+       newbin - justeport \
+               < <(sed -e "s:LIBDIR:$(get_libdir):" "${FILESDIR}"/wrapper-script)
        dodoc AUTHORS ChangeLog README THANKS
 }