dev-python/cffi: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Fri, 21 Aug 2015 09:30:10 +0000 (11:30 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 21 Aug 2015 09:35:05 +0000 (11:35 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/cffi/Manifest
dev-python/cffi/cffi-1.2.1.ebuild [new file with mode: 0644]

index 5100f95b39329c8b0d04e2d71c7639f9695c27a9..cbc1b22681d1049edcc23383984a4a359996979d 100644 (file)
@@ -4,3 +4,4 @@ DIST cffi-1.0.2.tar.gz 317360 SHA256 a5a8937f8a1e3c65d5ff9258137d2d08b6ca6dbee7c
 DIST cffi-1.0.3.tar.gz 317372 SHA256 4fdede789f446fb6c57eed8cf5eb43d2a582a34536ff2cd1edf7256e17e9046c SHA512 a5f2b0ab356fe51b1d9f3f2e4bfadbc11bb10ec7f9458c019f3707b738dded1953723f797a8b37ed768cd14fe86f674d07d2cd5ce166406abaa1a68b443293b1 WHIRLPOOL 176c9acb1fb02c2e074d371b337f307b3cb7a473a05c016aa160c0caf6f680be1fcfaa6b9756aa88e7ca8008e5b4e47b58ab8de7078e97d53813dec51525eac3
 DIST cffi-1.1.0.tar.gz 323962 SHA256 d8c1dcef421bf3b9335925dd5bf39c3fad923a3cbd814c3664d754638b32355e SHA512 c9725869ffb8a10b83484b4b90ee02c66aa38a439334a404e043452de894f97f37050d7ba2467531820a6fdc7ee93a529078734e22b3637c5116d7d6d4b86ca0 WHIRLPOOL 4747675071ed4223def2b2a17429c1cadd2bfcae582ada6167f076065b6dc91fe06775e1d31c5f65fa68ea597dfdca36d9bab89e263affa1c25fe7c8f0e65d4a
 DIST cffi-1.1.2.tar.gz 326758 SHA256 390970b602708c91ddc73953bb6929e56291c18a4d80f360afa00fad8b6f3339 SHA512 d146984013b63382ea64bd2d6188cdbf9154cf83d66bf4dbb9353f1daea66f9eae07c6da47e152c5758d3458a742adde0310f71c792eb0a80950d7f857bfb943 WHIRLPOOL 02b92f0d13b02e351ba63e55a731c0b5480ae0b376c99a8dc1a256b3b55bf0119b4238dca88171605c1348b0847a6ff305ba4ec69cd1b42b9950708f42d6067e
+DIST cffi-1.2.1.tar.gz 335778 SHA256 eab571deb0a152e2f53c404c08a94870a131526896cad08cd43bf86ce3771e3d SHA512 26ab695d34ef1895f38c735b2c6400cbf6325d622ce93799513130791365bb71d656288e991b86861ac8e899872504c1f4368d27104c4ac9b881c83c7f8dad88 WHIRLPOOL a8bbe3c24be660946c1f31fbb8b1f50810f78b9485a32aadfb091a624b5386641bde71981c58792f8e95e8e77cfce7d9959eb197c417464cf5351e568aa6336d
diff --git a/dev-python/cffi/cffi-1.2.1.ebuild b/dev-python/cffi/cffi-1.2.1.ebuild
new file mode 100644 (file)
index 0000000..4d1ec48
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/ https://pypi.python.org/pypi/cffi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc"
+
+RDEPEND="
+       virtual/libffi
+       dev-python/pycparser[${PYTHON_USEDEP}]
+       dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+       use doc && emake -C doc html
+}
+
+python_test() {
+       py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+       distutils-r1_python_install_all
+}