media-libs/rlottie: bump to latest commit, 20191101
authorJoonas Niilola <juippis@gentoo.org>
Fri, 1 Nov 2019 12:38:20 +0000 (14:38 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 1 Nov 2019 12:38:20 +0000 (14:38 +0200)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-libs/rlottie/Manifest
media-libs/rlottie/rlottie-0.0.1_pre20191101.ebuild [new file with mode: 0644]

index 0a8e05f4f9994a30d395f9feea35c42ccc8d0ce5..83d307c1e78d8540a8f58602e23d08cd0dd5b760 100644 (file)
@@ -1 +1,2 @@
 DIST rlottie-0.0.1_pre20190920.tar.gz 7891127 BLAKE2B bc9e37e74f21f681fffae3e6140662782ebce7bee58c4205cdb9f927f5246aedc83efc516adecf6c61fb5fc06aff58d1c65bfe3cca18d02bf4e9f2d71890869e SHA512 8d903e877cb83fd0af8cb7b6dd96e09a423201c0b88b2c8c733e54bb873a7b48377e5eb8eeefa620e284c2d1b61fcfe0aa309d180c88428aaccdb0f1ac4a48ed
+DIST rlottie-0.0.1_pre20191101.tar.gz 7896379 BLAKE2B 2361415074af71340c80b91595edab0b53e85ce704400ba5574e1efc19e6bc2cd7dff8b0e2d32b9f0666889c4d8bd2abbffa943f551b4ee3e4787aa94cfbbe01 SHA512 c4c4dae0f0da4d0bd4b3ea63066335794111f1bd4a33f8844494b9b9e79de46cd994b5e9d185b175cba19d1665ef1fdb0d89babfd71cf7dd0fbf0535ba83ab96
diff --git a/media-libs/rlottie/rlottie-0.0.1_pre20191101.ebuild b/media-libs/rlottie/rlottie-0.0.1_pre20191101.ebuild
new file mode 100644 (file)
index 0000000..37f6c96
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+MY_COMMIT="ddf0f149aaee7625f8cde1ae15f0605e57274445"
+
+DESCRIPTION="A platform independent standalone library that plays Lottie Animations"
+HOMEPAGE="https://www.tizen.org/ https://github.com/Samsung/rlottie"
+SRC_URI="https://github.com/Samsung/rlottie/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD FTL LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+S="${WORKDIR}/rlottie-${MY_COMMIT}"
+
+PATCHES=( "${FILESDIR}"/rlottie-0.0.1_pre20190920-disable-werror.patch )
+
+src_configure() {
+       local emesonargs=(
+               -D example=false
+               $(meson_use test)
+       )
+
+       meson_src_configure
+}
+
+src_test() {
+       cd "${BUILD_DIR}" || die "Failed to switch into BUILD_DIR."
+       eninja test
+}