net-misc/linuxptp: Version bump
authorThomas Beierlein <tomjbe@gentoo.org>
Sun, 20 Jan 2019 14:56:34 +0000 (15:56 +0100)
committerThomas Beierlein <tomjbe@gentoo.org>
Sun, 20 Jan 2019 14:56:34 +0000 (15:56 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
net-misc/linuxptp/Manifest
net-misc/linuxptp/linuxptp-2.0.ebuild [new file with mode: 0644]

index 5e3edb0535c25729d9216be20094641f193ca0e6..fe7f8d28d7022ff7cdc1a75eb46517f189107537 100644 (file)
@@ -1 +1,2 @@
 DIST linuxptp-1.8.tgz 147764 BLAKE2B f0dec589cf4f27c03f901262980f1c471382eefdd00772da0065077bab29ed7c1350d70b1ec4b0c912dd82304220b9c550320b82cf269d99478d40c5a7ed8541 SHA512 8ac52428b7addf1c43769083e660ca0ceb2813994107b8b9c59338e480f1d2e45666ebcc3f59f7b8cf9a02301b55aa54b26cbbbf81622a525a704f2d08fd383e
+DIST linuxptp-2.0.tgz 184942 BLAKE2B 79ef9d3c379769a71e652a77f05ab661db444a76a339e72106055cf900de9cabfe303c48760f11701fefe5e641d07b73fc5a250078bedf7faa3ae995ace24da3 SHA512 c33487a803f8cc461f790d9a137d5cf8b35cb6d292bdd2cf7a16aa666359d8c5e24667473be843182bef1e9f8d5c6af8aab8918978f10bf08257dd408bba66d6
diff --git a/net-misc/linuxptp/linuxptp-2.0.ebuild b/net-misc/linuxptp/linuxptp-2.0.ebuild
new file mode 100644 (file)
index 0000000..c0b5ed6
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="The Linux Precision Time Protocol (PTP) implementation"
+HOMEPAGE="http://linuxptp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/v${PV}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="PPS NETWORK_PHY_TIMESTAMPING PTP_1588_CLOCK"
+
+src_compile() {
+       export EXTRA_CFLAGS=${CFLAGS}
+       emake prefix=/usr mandir=/usr/share/man
+}
+
+src_install() {
+       emake \
+               prefix="${D}"/usr \
+               mandir="${D}"/usr/share/man \
+               infodir="${D}"/usr/share/info \
+               libdir="${D}"/usr/$(get_libdir) \
+               install
+
+       dodoc README.org
+}