---- Makefile
-+++ Makefile 2003-10-12 02:25:31.000000000 +0000
+--- a/Makefile
++++ b/Makefile 2003-10-12 02:25:31.000000000 +0000
@@ -4,7 +4,7 @@
\r
### Sources\r
file_io.o : s_types.h file_io.h file_io.c\r
in_buffer.o : s_types.h file_io.h in_buffer.h in_buffer.c\r
main.o : s_types.h file_io.h vstrip.h main.c\r
---- dvd2avi_plugin.c
-+++ dvd2avi_plugin.c 2003-10-12 02:29:23.000000000 +0000
+--- a/dvd2avi_plugin.c
++++ b/dvd2avi_plugin.c 2003-10-12 02:29:23.000000000 +0000
@@ -6,13 +6,17 @@
\r
*************************************************************************/\r
\r
lba = (dword)(fposition / fio_SECTOR_SIZE);\r
_close(fp);\r
---- file_io.c
-+++ file_io.c 2003-10-12 02:24:46.000000000 +0000
+--- a/file_io.c
++++ b/file_io.c 2003-10-12 02:24:46.000000000 +0000
@@ -32,7 +32,7 @@
fp = _open(name, _O_BINARY | _O_RDONLY); // check size\r
if (fp != -1)\r
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit eutils toolchain-funcs
IUSE=""
DEPEND="app-arch/unzip"
-RDEPEND=""
S="${WORKDIR}/${PN}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gentoo.patch
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-gentoo.patch
edos2unix *.c *.h
- for file in *.c *.h ; do
- echo >>$file
+ local f
+ for f in *.c *.h ; do
+ echo >> "${f}" || die
done
+
+ default
}
src_compile() {
- emake CFLAGS="${CFLAGS} -D__UNIX__" CC="$(tc-getCC)" || die "emake failed."
+ emake CFLAGS="${CFLAGS} -D__UNIX__" CC="$(tc-getCC)"
}
src_install() {