dev-libs/appstream: Fix build with USE !test
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 24 Jan 2019 23:16:28 +0000 (00:16 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 24 Jan 2019 23:16:28 +0000 (00:16 +0100)
Closes: https://bugs.gentoo.org/675944
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/appstream/appstream-0.12.4.ebuild

index 315dc0c2acdb0ef08702cf8a73b41eaf98c46933..b64ac55e0487ceaca1c141086d12aad5754ecf32 100644 (file)
@@ -47,6 +47,9 @@ RDEPEND="${DEPEND}"
 src_prepare() {
        default
        sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
+       if ! use test; then
+               sed -e "/^subdir.*tests/s/^/#DONT /" -i {,qt/}meson.build || die # bug 675944
+       fi
 }
 
 src_configure() {