dev-python/zope-testing: 4.7 bump
authorWilliam Hubbs <williamh@gentoo.org>
Sun, 10 Mar 2019 02:32:35 +0000 (20:32 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Sun, 10 Mar 2019 02:37:57 +0000 (20:37 -0600)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-python/zope-testing/Manifest
dev-python/zope-testing/zope-testing-4.7.ebuild [new file with mode: 0644]

index c60b1376f03900d5e151041d8fb3bd72c234ecc3..2848b3e9f6ebfbd9e899e264435b320f1c010143 100644 (file)
@@ -1 +1,2 @@
 DIST zope.testing-4.6.2.tar.gz 62710 BLAKE2B 4b70538dc8bbbc4445bcdc8eb2d49c36b4fede893a50007367195aa1017b088ae65805b59566daefd7cfad612ca20c24659cb3da65aa3e307cad3aaa03c67178 SHA512 816c87a38c847aad67857c364bb9999f4283484c933be2bcb54066dac4a6f8c6f94dfde61860397003e7f17b8669e7964a7fbe28e7ca7313f5d131f17c0b672d
+DIST zope.testing-4.7.tar.gz 63474 BLAKE2B dc825849c288b9f8ab9e4edfe670e09aa49f28c64047da8e0fb36cbfa6cf24d70cf6a49ea8a51ca1831b152f3ffa4b0c62cde29750036f13c9f754df2bb80da2 SHA512 cdf87f95196880a0f55c740f6340286bb29e96e9273d0c645bbb50def54a0645cce22d971adba3f15ff57b1021a72749219af83abc4e8fa775fb982d8164791d
diff --git a/dev-python/zope-testing/zope-testing-4.7.ebuild b/dev-python/zope-testing/zope-testing-4.7.ebuild
new file mode 100644 (file)
index 0000000..4485c27
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope testing helpers"
+HOMEPAGE="https://pypi.org/project/zope.testing/ https://github.com/zopefoundation/zope.testing"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       # remove .pth files since dev-python/namespace-zope handles the ns
+       find "${D}" -name '*.pth' -delete || die
+}