net-wireless/bluez: Fix building in non-glibc systems
authorPacho Ramos <pacho@gentoo.org>
Sun, 20 Oct 2019 08:55:02 +0000 (10:55 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 20 Oct 2019 08:55:47 +0000 (10:55 +0200)
Thanks-to: Jory A. Pratt
Closes: https://bugs.gentoo.org/695940
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
net-wireless/bluez/bluez-5.51.ebuild
net-wireless/bluez/files/bluez-5.51-include-limits-h.patch [new file with mode: 0644]

index 00a51cb60471b258dd50d1e6a87fe683f51e2a19..792792341b4f3b1527a9a56a6ee277b5719497f2 100644 (file)
@@ -69,6 +69,11 @@ PATCHES=(
        # http://article.gmane.org/gmane.linux.bluez.kernel/67230
        "${FILESDIR}"/${PN}-5.39-systemd-quote.patch
 
+       # Include limits.h for PATH_MAX
+       # https://marc.info/?l=linux-bluetooth&m=157156119320950&w=2
+       # https://bugs.gentoo.org/695940
+       "${FILESDIR}"/${PN}-5.51-include-limits-h.patch
+
        # Fedora patches
        # http://www.spinics.net/lists/linux-bluetooth/msg40136.html
        "${FILESDIR}"/0001-obex-Use-GLib-helper-function-to-manipulate-paths.patch
diff --git a/net-wireless/bluez/files/bluez-5.51-include-limits-h.patch b/net-wireless/bluez/files/bluez-5.51-include-limits-h.patch
new file mode 100644 (file)
index 0000000..ccbc152
--- /dev/null
@@ -0,0 +1,64 @@
+From 20128c5c95fbae93c9fd996d5ad2584cf6ad8032 Mon Sep 17 00:00:00 2001
+From: Jory Pratt <anarchy@gentoo.org>
+Date: Mon, 30 Sep 2019 18:35:56 -0500
+Subject: [PATCH] Include limits.h for PATH_MAX
+
+Signed-off-by: Jory Pratt <anarchy@gentoo.org>
+---
+ mesh/keyring.c          | 1 +
+ mesh/mesh-config-json.c | 1 +
+ mesh/node.c             | 1 +
+ mesh/util.c             | 1 +
+ 4 files changed, 4 insertions(+)
+
+diff --git a/mesh/keyring.c b/mesh/keyring.c
+index 3a7f92f..9fa7d6b 100644
+--- a/mesh/keyring.c
++++ b/mesh/keyring.c
+@@ -24,6 +24,7 @@
+ #define _GNU_SOURCE
+ #include <fcntl.h>
+ #include <dirent.h>
++#include <limits.h>
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <dirent.h>
+diff --git a/mesh/mesh-config-json.c b/mesh/mesh-config-json.c
+index cafa2fd..74ca495 100644
+--- a/mesh/mesh-config-json.c
++++ b/mesh/mesh-config-json.c
+@@ -27,6 +27,7 @@
+ #include <fcntl.h>
+ #include <ftw.h>
+ #include <libgen.h>
++#include <limits.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
+diff --git a/mesh/node.c b/mesh/node.c
+index b6824f5..15dcb97 100644
+--- a/mesh/node.c
++++ b/mesh/node.c
+@@ -23,6 +23,7 @@
+ #define _GNU_SOURCE
+ #include <dirent.h>
++#include <limits.h>
+ #include <stdio.h>
+ #include <sys/time.h>
+diff --git a/mesh/util.c b/mesh/util.c
+index 1455bde..986ba4b 100644
+--- a/mesh/util.c
++++ b/mesh/util.c
+@@ -25,6 +25,7 @@
+ #include <dirent.h>
+ #include <ftw.h>
+ #include <stdio.h>
++#include <limits.h>
+ #include <time.h>
+ #include <sys/time.h>
+-- 
+2.23.0
+