dev-vcs/gitolite: use HTTPS for GitHub, fix redirected URL in doc
authorDavid Hicks <david@hicks.id.au>
Sat, 29 Jul 2017 16:14:04 +0000 (02:14 +1000)
committerMichał Górny <mgorny@gentoo.org>
Sun, 30 Jul 2017 09:38:00 +0000 (11:38 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-vcs/gitolite/gitolite-3.6.1.ebuild
dev-vcs/gitolite/gitolite-3.6.2-r1.ebuild
dev-vcs/gitolite/gitolite-3.6.2.ebuild
dev-vcs/gitolite/gitolite-3.6.3.ebuild
dev-vcs/gitolite/gitolite-3.6.4-r1.ebuild
dev-vcs/gitolite/gitolite-3.6.4.ebuild
dev-vcs/gitolite/gitolite-3.6.5.ebuild
dev-vcs/gitolite/gitolite-3.6.6.ebuild
dev-vcs/gitolite/gitolite-3.6.7.ebuild
dev-vcs/gitolite/gitolite-3.6.ebuild
dev-vcs/gitolite/gitolite-9999.ebuild

index 9c0acb573f55da1cb214b10bcfadd80a59b94196..30a7fda7883a6120853f15c18198607ac4dc9751 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -7,7 +7,7 @@ inherit perl-module user versionator
 
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
-SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
@@ -71,7 +71,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index 9401738c254ab5227ee5ff339d140ee8bc68a96f..a1fb9c6b9da4f7b17e913923371d27af152fc5b8 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 [[ ${PV} == *9999 ]] && SCM="git-2"
-EGIT_REPO_URI="git://github.com/sitaramc/gitolite.git"
+EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
 EGIT_MASTER=master
 
 inherit perl-module user versionator ${SCM}
@@ -11,7 +11,7 @@ inherit perl-module user versionator ${SCM}
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
 if [[ ${PV} != *9999 ]]; then
-       SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~x86"
 else
        SRC_URI=""
@@ -84,7 +84,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index 4dcc7673b25940b89673083aa7e0fcd36c3df9ee..10f8ddcbf3f9c000572ce9106e0765268a8a4bcc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -7,7 +7,7 @@ inherit perl-module user versionator
 
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
-SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
@@ -71,7 +71,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index 1b067e1f085e68b8330ed32bc70cfe7f1dd385b9..4fc56440480202d01a7a3b999cf925b8fbb2902f 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 [[ ${PV} == *9999 ]] && SCM="git-2"
-EGIT_REPO_URI="git://github.com/sitaramc/gitolite.git"
+EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
 EGIT_MASTER=master
 
 inherit perl-module user versionator ${SCM}
@@ -11,7 +11,7 @@ inherit perl-module user versionator ${SCM}
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
 if [[ ${PV} != *9999 ]]; then
-       SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="amd64 ~arm x86"
 else
        SRC_URI=""
@@ -85,7 +85,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index 3867954db299b2edd5c10678c5b00705f672e24c..928bbe83926c7f306f2f52f719572353b04dd187 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 [[ ${PV} == *9999 ]] && SCM="git-2"
-EGIT_REPO_URI="git://github.com/sitaramc/gitolite.git"
+EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
 EGIT_MASTER=master
 
 inherit perl-module user versionator ${SCM}
@@ -11,7 +11,7 @@ inherit perl-module user versionator ${SCM}
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
 if [[ ${PV} != *9999 ]]; then
-       SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~x86"
 else
        SRC_URI=""
@@ -85,7 +85,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index 2b14d38c04467f90118a73a60081837575e2c8bb..26ef161375f9ce4d309dd3428bdb3c4eb9e1145f 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 [[ ${PV} == *9999 ]] && SCM="git-2"
-EGIT_REPO_URI="git://github.com/sitaramc/gitolite.git"
+EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
 EGIT_MASTER=master
 
 inherit perl-module user versionator ${SCM}
@@ -11,7 +11,7 @@ inherit perl-module user versionator ${SCM}
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
 if [[ ${PV} != *9999 ]]; then
-       SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~x86"
 else
        SRC_URI=""
@@ -85,7 +85,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index 3867954db299b2edd5c10678c5b00705f672e24c..928bbe83926c7f306f2f52f719572353b04dd187 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 [[ ${PV} == *9999 ]] && SCM="git-2"
-EGIT_REPO_URI="git://github.com/sitaramc/gitolite.git"
+EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
 EGIT_MASTER=master
 
 inherit perl-module user versionator ${SCM}
@@ -11,7 +11,7 @@ inherit perl-module user versionator ${SCM}
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
 if [[ ${PV} != *9999 ]]; then
-       SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~x86"
 else
        SRC_URI=""
@@ -85,7 +85,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index 5c9fe9b28330c805329030c4f6b88970da16a452..10ab3eef999bc8238be432a82a0b9b5d245b5081 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 [[ ${PV} == *9999 ]] && SCM="git-2"
-EGIT_REPO_URI="git://github.com/sitaramc/gitolite.git"
+EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
 EGIT_MASTER=master
 
 inherit perl-module user versionator ${SCM}
@@ -11,7 +11,7 @@ inherit perl-module user versionator ${SCM}
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
 if [[ ${PV} != *9999 ]]; then
-       SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="amd64 ~arm x86"
 else
        SRC_URI=""
@@ -88,7 +88,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index fe7002e9ed889a32d07105a04db77c9ff2db95a1..cd1b715bb24de7941e2998d8cb5a884983f29270 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 [[ ${PV} == *9999 ]] && SCM="git-2"
-EGIT_REPO_URI="git://github.com/sitaramc/gitolite.git"
+EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
 EGIT_MASTER=master
 
 inherit perl-module user versionator ${SCM}
@@ -11,7 +11,7 @@ inherit perl-module user versionator ${SCM}
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
 if [[ ${PV} != *9999 ]]; then
-       SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~x86"
 else
        SRC_URI=""
@@ -88,7 +88,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index 6d1426bdefd98f91958a515e22ad838d10fc2df7..91aadb96030901e8524baeee14a465f7f00f9039 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -7,7 +7,7 @@ inherit perl-module user versionator
 
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
-SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
@@ -71,7 +71,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291
index 3867954db299b2edd5c10678c5b00705f672e24c..928bbe83926c7f306f2f52f719572353b04dd187 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 [[ ${PV} == *9999 ]] && SCM="git-2"
-EGIT_REPO_URI="git://github.com/sitaramc/gitolite.git"
+EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
 EGIT_MASTER=master
 
 inherit perl-module user versionator ${SCM}
@@ -11,7 +11,7 @@ inherit perl-module user versionator ${SCM}
 DESCRIPTION="Highly flexible server for git directory version tracker"
 HOMEPAGE="https://github.com/sitaramc/gitolite"
 if [[ ${PV} != *9999 ]]; then
-       SRC_URI="https://github.com/sitaramc/gitolite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~x86"
 else
        SRC_URI=""
@@ -85,7 +85,7 @@ pkg_postinst() {
        if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
                ewarn
                elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr.html first!"
+               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
        fi
 
        # bug 352291