app-editors/nano: version bump to 2.7.5
authorMike Frysinger <vapier@gentoo.org>
Thu, 23 Feb 2017 19:08:09 +0000 (14:08 -0500)
committerMike Frysinger <vapier@gentoo.org>
Thu, 23 Feb 2017 19:08:17 +0000 (14:08 -0500)
app-editors/nano/Manifest
app-editors/nano/nano-2.7.5.ebuild [new file with mode: 0644]

index 3183cbfc0d4fbb24040c6554488525aa4f93da8c..9c6a23e5e70ac43994e4f882c3b3a9ce4f291e19 100644 (file)
@@ -1,3 +1,4 @@
 DIST nano-2.5.3.tar.gz 1967760 SHA256 b2b060129b9feff2d4870d803a441178c96531de9aed144ec0b83bd63ccb12ee SHA512 1d859f0bd88b9d907cfcaa84edc212bcaea4335c203922eb5b7378c2b45d88dffe1f3e4cb499a824d33781485834ef564997c58cf1fd92610d08f6ce8dcb67d5 WHIRLPOOL a2ca1c41d3cb26756cc9aba5b5fa0aeaea220626b98d0abfa1c5c4d4d57c3a5ef688d5edf00a6a00849ee25a67b2bbab93c4d454f6eb5a204b10fa01de3e298f
 DIST nano-2.6.3.tar.gz 2019354 SHA256 4f4054e12f2181c8e436163e931a0a565612242ff9e566c4d1adeda0f91fd503 SHA512 5079c0da976e3cfef9f3980e37c2501837bc66bb98fadd6fe7f02b061b83c99454678833fd43c74e6796cdc4ee9028ccba7a8a05e0f86e7a6517ba4d4c6bc95e WHIRLPOOL 94520ca9c7a11342133adfd3a1e9e9c77a6c07ab18b1b51bf39918b331abc6bd7ebeb937c2ec8ed3e59b8d0468e40f4e5811e66a8aecd469ad42c595c1b61fe4
 DIST nano-2.7.4.tar.gz 2023560 SHA256 23ffc2de52d687739fed6dc2fc94df36aa7da7bb52c8740c523fdd7336fdbc8c SHA512 029fa2ef72a8762f376f1cfc3f4cdcabfcb226868e5c68c5980162333099f23e74e77da2dda66b4e70e2840b9a0e472db821248327b417b3cf5132093eeb80ee WHIRLPOOL 9fb363d52c538165d73828aec6564cf9b79612e2fd489c3edfa4db8049d676cba2c668f4f704df4fc31f9b6cea738c63fc2b2c3e0b0d0cde0b1f72a4226bc391
+DIST nano-2.7.5.tar.gz 2031723 SHA256 226be22f46359007aa76499623739f4a7d5fa294a2899c70b21bc09b8d81d907 SHA512 a5332a361c4d0d9d0a77ebb11cdcffa976bee4981d5665b2732a9e6d7a2997566d9345332f2e6e5cb74f0a81be4413f54ca8f719962ab10b32d7ec1c9271973c WHIRLPOOL bd28cde96896ad531bb499504bb1438b358b64e7f6080fa24758bee7c222b4d1df0c395d480d0cef54de8e78a7e457db403a9ef2d6a56033e65299b6d7f95634
diff --git a/app-editors/nano/nano-2.7.5.ebuild b/app-editors/nano/nano-2.7.5.ebuild
new file mode 100644 (file)
index 0000000..d649a73
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="git://git.sv.gnu.org/nano.git"
+       inherit git-r3 autotools
+else
+       MY_P=${PN}-${PV/_}
+       SRC_URI="https://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify +magic minimal ncurses nls slang +spell static unicode"
+
+LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
+       sys-libs/ncurses:0=[static-libs(+)]
+       magic? ( sys-apps/file[static-libs(+)] )
+       nls? ( virtual/libintl )
+       !ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+       nls? ( sys-devel/gettext )
+       virtual/pkgconfig
+       static? ( ${LIB_DEPEND} )"
+
+src_prepare() {
+       if [[ ${PV} == "9999" ]] ; then
+               eautoreconf
+       fi
+       epatch_user
+}
+
+src_configure() {
+       use static && append-ldflags -static
+       local myconf=()
+       case ${CHOST} in
+       *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
+       esac
+       econf \
+               --bindir="${EPREFIX}"/bin \
+               --htmldir=/trash \
+               $(use_enable !minimal color) \
+               $(use_enable !minimal multibuffer) \
+               $(use_enable !minimal nanorc) \
+               --disable-wrapping-as-root \
+               $(use_enable magic libmagic) \
+               $(use_enable spell speller) \
+               $(use_enable justify) \
+               $(use_enable debug) \
+               $(use_enable nls) \
+               $(use_enable unicode utf8) \
+               $(use_enable minimal tiny) \
+               $(usex ncurses --without-slang $(use_with slang)) \
+               "${myconf[@]}"
+}
+
+src_install() {
+       default
+       rm -rf "${D}"/trash
+
+       dodoc doc/sample.nanorc
+       docinto html
+       dodoc doc/faq.html
+       insinto /etc
+       newins doc/sample.nanorc nanorc
+       if ! use minimal ; then
+               # Enable colorization by default.
+               sed -i \
+                       -e '/^# include /s:# *::' \
+                       "${ED}"/etc/nanorc || die
+       fi
+
+       dodir /usr/bin
+       dosym /bin/nano /usr/bin/nano
+}