net-nds/yp-tools: Always use libtirpc, should fix bug 630246
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 3 Mar 2018 22:35:56 +0000 (23:35 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 3 Mar 2018 22:36:21 +0000 (23:36 +0100)
Closes: https://bugs.gentoo.org/630246
Package-Manager: Portage-2.3.24, Repoman-2.3.6

net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild [new file with mode: 0644]

diff --git a/net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild b/net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild
new file mode 100644 (file)
index 0000000..3146786
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit systemd
+
+DESCRIPTION="Network Information Service tools"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+SRC_URI="http://www.linux-nis.org/download/yp-tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="
+       net-libs/libtirpc
+       net-libs/libnsl:0=
+"
+RDEPEND=${DEPEND}
+# uses always libtirpc if present
+
+RESTRICT=test # do not compile
+
+src_configure () {
+       econf \
+               --disable-static \
+               --sysconfdir=/etc/yp \
+               $(use_enable nls)
+}
+
+src_install() {
+       default
+
+       insinto /etc/yp
+       doins etc/nicknames
+
+       systemd_dounit "${FILESDIR}/domainname.service"
+       systemd_install_serviced "${FILESDIR}"/domainname.service.conf
+}