dev-ml/dose3: fix build with latest extlib.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 14 Sep 2015 15:48:30 +0000 (17:48 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 14 Sep 2015 15:50:17 +0000 (17:50 +0200)
Package-Manager: portage-2.2.20.1

dev-ml/dose3/dose3-3.3.ebuild
dev-ml/dose3/files/extlib.patch [new file with mode: 0644]

index 808c7afc8e275f2a418671fcd455dd83a47b446f..f9ac6f60244580aa2de4e955e646b567aa86729f 100644 (file)
@@ -4,6 +4,8 @@
 
 EAPI=5
 
+inherit eutils
+
 MY_P="${P/_beta/-beta}"
 DESCRIPTION="Library and a collection of tools to perform la large spectrum of analysis on package repositories"
 HOMEPAGE="http://dose.gforge.inria.fr/public_html/"
@@ -39,6 +41,7 @@ S="${WORKDIR}/${MY_P}"
 
 src_prepare() {
        sed -e 's/INSTALLOPTS=-s/INSTALLOPTS=/' -i Makefile.config.in || die
+       has_version '>=dev-ml/extlib-1.7' && epatch "${FILESDIR}/extlib.patch"
 }
 
 src_configure() {
diff --git a/dev-ml/dose3/files/extlib.patch b/dev-ml/dose3/files/extlib.patch
new file mode 100644 (file)
index 0000000..f4a16de
--- /dev/null
@@ -0,0 +1,12 @@
+Index: dose3-3.3/doseparse/stdOptions.ml
+===================================================================
+--- dose3-3.3.orig/doseparse/stdOptions.ml
++++ dose3-3.3/doseparse/stdOptions.ml
+@@ -20,6 +20,7 @@ include Util.Logging(struct let label =
+ module type Ot = sig
+   val options :
+     ?usage:string ->
++    ?status:int ->
+     ?version:string ->
+     ?suppress_usage:bool ->
+     ?suppress_help:bool ->