media-gfx/exiv2: Remove linguas_* from IUSE.
authorUlrich Müller <ulm@gentoo.org>
Sat, 6 Jan 2018 19:02:29 +0000 (20:02 +0100)
committerUlrich Müller <ulm@gentoo.org>
Sat, 6 Jan 2018 19:03:20 +0000 (20:03 +0100)
Do not assign the LINGUAS variable in global scope, as it would
override the user's setting. Account for unset LINGUAS.

Package-Manager: Portage-2.3.19, Repoman-2.3.6

media-gfx/exiv2/exiv2-0.26_p20171104-r1.ebuild
media-gfx/exiv2/exiv2-0.26_p20171104.ebuild

index f7eb67dc5bf29ca74f61e8e6ca7333db810586d5..7553fc67ec9af621e244393d6083187b24aa6fe1 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-LINGUAS="bs de es fi fr gl ms pl pt ru sk sv ug uk vi"
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 if [[ ${PV} = *9999 ]]; then
        EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
@@ -21,7 +20,7 @@ HOMEPAGE="http://www.exiv2.org/"
 
 LICENSE="GPL-2"
 SLOT="0/26"
-IUSE="doc examples nls png webready xmp $(printf 'linguas_%s ' ${LINGUAS})"
+IUSE="doc examples nls png webready xmp"
 
 RDEPEND="
        >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
@@ -63,7 +62,8 @@ src_prepare() {
                        pushd po > /dev/null || die
                        local lang
                        for lang in *.po; do
-                               if [[ -e ${lang} ]] && ! has ${lang/.po/} ${LINGUAS} ; then
+                               if [[ -e ${lang} ]] \
+                                               && ! has ${lang/.po/} ${LINGUAS-${lang/.po/}} ; then
                                        case ${lang} in
                                                CMakeLists.txt | \
                                                ${PN}.pot)      ;;
index 9450566668f18d8ff19321de2fee06655581e9db..4bd63be4e67f17388414abcf4016cac9ca86527e 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-LINGUAS="bs de es fi fr gl ms pl pt ru sk sv ug uk vi"
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 if [[ ${PV} = *9999 ]]; then
        EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
@@ -21,7 +20,7 @@ HOMEPAGE="http://www.exiv2.org/"
 
 LICENSE="GPL-2"
 SLOT="0/26"
-IUSE="doc examples nls png webready xmp $(printf 'linguas_%s ' ${LINGUAS})"
+IUSE="doc examples nls png webready xmp"
 
 RDEPEND="
        >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
@@ -62,7 +61,8 @@ src_prepare() {
                        pushd po > /dev/null || die
                        local lang
                        for lang in *.po; do
-                               if [[ -e ${lang} ]] && ! has ${lang/.po/} ${LINGUAS} ; then
+                               if [[ -e ${lang} ]] \
+                                               && ! has ${lang/.po/} ${LINGUAS-${lang/.po/}} ; then
                                        case ${lang} in
                                                CMakeLists.txt | \
                                                ${PN}.pot)      ;;