app-misc/mosquitto: bump version to 1.4.15
authorlramage94 <ramage.lucas@openmailbox.org>
Sun, 4 Mar 2018 22:32:41 +0000 (17:32 -0500)
committerMichał Górny <mgorny@gentoo.org>
Fri, 23 Mar 2018 22:27:39 +0000 (23:27 +0100)
Closes: https://github.com/gentoo/gentoo/pull/7362
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-misc/mosquitto/Manifest
app-misc/mosquitto/mosquitto-1.4.15.ebuild [new file with mode: 0644]

index 781bd37391c554ded40914280289717a59a2e225..e57c2e973ef3582c9203ba3bed652b51fc255d83 100644 (file)
@@ -1 +1,2 @@
 DIST mosquitto-1.4.14.tar.gz 365596 BLAKE2B 92bcb1fd9e67711d6ce8db5e767be31a1321866205cf4cad684d8b77a8b14a2eaf5e4367a74d5dd8f814f0d229dc77ce878879632c0c34c6a23f7975bf6ae8c7 SHA512 dc75a971354f87deeb79f32435acfae9bc561a1a24a75ee4940a35176ff91758071930d2105d8dee2a090e07527dbfaa5692bece67e03cc87e8b4b8b46f846c2
+DIST mosquitto-1.4.15.tar.gz 368961 BLAKE2B 28bfab7d41d9e057ba8b52e0c428967ecc5d0c25a3d73dca420ae883c2b462ee02da1eeb9c22f4d392f0ccf62224acab6f24d4a0798a594f4b9f90c907fa1495 SHA512 36b06547553cf28af3ca9b728c42fc27e849c4ae84d7964572d430233ab26e2b59eee2a215ac23ddf2d0bef419e7c70e64e2a22c397fadb3e0677314d03f1100
diff --git a/app-misc/mosquitto/mosquitto-1.4.15.ebuild b/app-misc/mosquitto/mosquitto-1.4.15.ebuild
new file mode 100644 (file)
index 0000000..65dffc2
--- /dev/null
@@ -0,0 +1,99 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit systemd user toolchain-funcs python-any-r1
+
+DESCRIPTION="An Open Source MQTT v3 Broker"
+HOMEPAGE="http://mosquitto.org/"
+SRC_URI="http://mosquitto.org/files/source/${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="bridge examples +persistence +srv ssl tcpd test websockets"
+
+REQUIRED_USE="test? ( bridge )"
+
+RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
+       ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       srv? ( net-dns/c-ares )
+       websockets? ( net-libs/libwebsockets )"
+
+_emake() {
+       LIBDIR=$(get_libdir)
+       emake \
+               CC="$(tc-getCC)" \
+               LIB_SUFFIX="${LIBDIR:3}" \
+               WITH_BRIDGE="$(usex bridge)" \
+               WITH_PERSISTENCE="$(usex persistence)" \
+               WITH_SRV="$(usex srv)" \
+               WITH_TLS="$(usex ssl)" \
+               WITH_WEBSOCKETS="$(usex websockets)" \
+               WITH_WRAP="$(usex tcpd)" \
+               "$@"
+}
+
+pkg_setup() {
+       enewgroup mosquitto
+       enewuser mosquitto -1 -1 -1 mosquitto
+}
+
+src_prepare() {
+       if use persistence; then
+               sed -i -e "/^#autosave_interval/s|^#||" \
+                       -e "s|^#persistence false$|persistence true|" \
+                       -e "/^#persistence_file/s|^#||" \
+                       -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
+                       mosquitto.conf || die
+       fi
+
+       # Remove prestripping
+       sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
+               client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
+
+       python_setup
+       python_fix_shebang test
+       eapply_user
+}
+
+src_compile() {
+       _emake
+}
+
+src_test() {
+       _emake test
+}
+
+src_install() {
+       _emake DESTDIR="${D}" prefix=/usr install
+       keepdir /var/lib/mosquitto
+       fowners mosquitto:mosquitto /var/lib/mosquitto
+       dodoc readme.md CONTRIBUTING.md ChangeLog.txt
+       doinitd "${FILESDIR}"/mosquitto
+       insinto /etc/mosquitto
+       doins mosquitto.conf
+       systemd_dounit "${FILESDIR}/mosquitto.service"
+
+       if use examples; then
+               docompress -x "/usr/share/doc/${PF}/examples"
+               docinto "/usr/share/doc/${PF}"
+               doins -r examples
+       fi
+}
+
+pkg_postinst() {
+       elog ""
+       elog "The Python module has been moved out of mosquitto."
+       elog "See http://mosquitto.org/documentation/python/"
+       elog ""
+       elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
+       elog ""
+       elog "    rc-update add mosquitto default"
+       elog "    or"
+       elog "    systemctl enable mosquitto"
+}