app-admin/supervisor: Bump
authorPatrick Lauer <patrick@gentoo.org>
Thu, 18 Feb 2016 09:57:00 +0000 (10:57 +0100)
committerPatrick Lauer <patrick@gentoo.org>
Thu, 18 Feb 2016 09:57:15 +0000 (10:57 +0100)
Package-Manager: portage-2.2.27

app-admin/supervisor/Manifest
app-admin/supervisor/supervisor-3.2.1.ebuild [new file with mode: 0644]

index 78a6a1775b37c2ea7b3cfc6b7925b5d9344999aa..96b864010e4a584e5b3a8e8a582e61164adfcffc 100644 (file)
@@ -1 +1,2 @@
 DIST supervisor-3.1.3.tar.gz 391529 SHA256 e32c546fe8d2a6e079ec4819c49fd24534d4075a58af39118d04367918b3c282 SHA512 40795bfd1aee3eba9e51b6dc1bfcff20c42c0a42ca7ceecc35c428f7840d5d631303b7f0c4eee85375296fd4e9a48f6b405a87caf038f8ffbfe227b5160e7aa5 WHIRLPOOL da8f41907857c46633e93e1806449babd9230994a528c73946276c10387e380763b7b9fb884bb3376537d6eb55428e5873ed8e9a11cd410a3d6c8d7593907552
+DIST supervisor-3.2.1.tar.gz 410461 SHA256 d6b54903aab4214664b6f2c6400f673bee3e21aec7b14d08940ed431a3ead630 SHA512 a4fa8b1729a578c36c989e91a87c0ff4d2e5487b1beb58bd0695729553b5005cf4a282c6a193330c5b352d2467597bae330a28d6e42305c8108593fbf24b1b80 WHIRLPOOL 36f798f87a73e76b8cd79d4c417a64246e77b3114142a82fc322f302deb285f625f6a1bab738cb437116665b6172a1b643fa8c765e57591500c53ed6823b3372
diff --git a/app-admin/supervisor/supervisor-3.2.1.ebuild b/app-admin/supervisor/supervisor-3.2.1.ebuild
new file mode 100644 (file)
index 0000000..049c53d
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )    # py2 only
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+MY_PV="${PV/_beta/b}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.python.org/pypi/supervisor"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+# ALL versions of meld3 match to >=meld3-0.6.5
+RDEPEND="dev-python/meld3[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? ( dev-python/mock[${PYTHON_USEDEP}] )
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_compile_all() {
+       # Somehow the test phase is called and run on invoking a doc build; harmless
+       use doc && emake -C docs html
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       newinitd "${FILESDIR}/init.d-r1" supervisord
+       newconfd "${FILESDIR}/conf.d" supervisord
+       use doc && local HTML_DOCS=( docs/.build/html/. )
+       distutils-r1_python_install_all
+}