dev-python/sphinx: Use typed-ast on py<3.8
authorMichał Górny <mgorny@gentoo.org>
Tue, 3 Mar 2020 17:20:05 +0000 (18:20 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 3 Mar 2020 17:45:59 +0000 (18:45 +0100)
dev-python/typed-ast is necessary for better typing support in py<3.8.
This also fixes (hopefully last) test failures.

Closes: https://bugs.gentoo.org/703140
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinx/sphinx-2.4.3-r1.ebuild [moved from dev-python/sphinx/sphinx-2.4.3.ebuild with 95% similarity]

similarity index 95%
rename from dev-python/sphinx/sphinx-2.4.3.ebuild
rename to dev-python/sphinx/sphinx-2.4.3-r1.ebuild
index 46f34931a946e37cd6600876c38b04b27a7f4b62..8063e70531844f2ffa21e0e30d8d1e2f7af83eb5 100644 (file)
@@ -37,6 +37,9 @@ RDEPEND="
        dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
        dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        dev-python/packaging[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/typed-ast[${PYTHON_USEDEP}]
+       ' python3_{6,7})
        latex? (
                dev-texlive/texlive-latexextra
                dev-texlive/texlive-luatex
@@ -64,7 +67,8 @@ python_prepare_all() {
        rm tests/test_build_linkcheck.py || die "Failed to remove web tests"
        sed -i -e 's:test_latex_images:_&:' tests/test_build_latex.py || die
 
-       # fail under pypy3
+       # fail under pypy3 (some because of missing typed-ast)
+       # revisit when pypy3 becomes pypy3.8
        sed -i -e '/def test_partialfunction/i\
 @pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
                -e '/def test_autodoc_typed_instance_variables/i\