net-wireless/bluez-tools: Fix compilation with gcc-10
authorOlivier Laurantin <olivier.laurantin@laposte.net>
Fri, 31 Jan 2020 07:01:05 +0000 (08:01 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 15:40:28 +0000 (17:40 +0200)
Closes: https://bugs.gentoo.org/707230
Signed-off-by: Olivier Laurantin <olivier.laurantin@laposte.net>
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Closes: https://github.com/gentoo/gentoo/pull/14510
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-wireless/bluez-tools/bluez-tools-0_p20161212.ebuild
net-wireless/bluez-tools/files/bluez-tools-0_p20161212-gcc-10.patch [new file with mode: 0644]

index 4e777054b46e88d42b3c952ce18757980276037c..87c36ffc4986f7c159da313862b5d8aa3a69c03b 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit autotools eutils
+inherit autotools
 
 DESCRIPTION="A set of tools to manage bluetooth devices for linux"
 HOMEPAGE="https://github.com/khvzak/bluez-tools"
@@ -23,9 +23,11 @@ DEPEND="${RDEPEND}"
 
 DOCS=( AUTHORS README )
 
+PATCHES=( "${FILESDIR}/${P}-gcc-10.patch" )
+
 S="${WORKDIR}/${PN}-${COMMIT}"
 
 src_prepare() {
+       default
        eautoreconf
-       default_src_prepare
 }
diff --git a/net-wireless/bluez-tools/files/bluez-tools-0_p20161212-gcc-10.patch b/net-wireless/bluez-tools/files/bluez-tools-0_p20161212-gcc-10.patch
new file mode 100644 (file)
index 0000000..6bfaa57
--- /dev/null
@@ -0,0 +1,29 @@
+--- a/src/lib/agent-helper.c   2016-12-12 09:18:08.000000000 +0100
++++ b/src/lib/agent-helper.c   2020-01-30 22:23:27.555951515 +0100
+@@ -33,6 +33,8 @@
+ #include "agent-helper.h"
++gboolean agent_need_unregister;
++
+ static const gchar *_bt_agent_introspect_xml = "<node name=\"/org/blueztools\">\n\t<interface name=\"org.bluez.Agent1\">\n\t\t<method name=\"Release\">\n\t\t</method>\n\t\t<method name=\"RequestPinCode\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"pincode\" direction=\"out\" type=\"s\"/>\n\t\t</method>\n\t\t<method name=\"DisplayPinCode\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"pincode\" direction=\"in\" type=\"s\"/>\n\t\t</method>\n\t\t<method name=\"RequestPasskey\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"passkey\" direction=\"out\" type=\"u\"/>\n\t\t</method>\n\t\t<method name=\"DisplayPasskey\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"passkey\" direction=\"in\" type=\"u\"/>\n\t\t\t<arg name=\"entered\" direction=\"in\" type=\"q\"/>\n\t\t</method>\n\t\t<method name=\"RequestConfirmation\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"passkey\" direction=\"in\" type=\"u\"/>\n\t\t</method>\n\t\t<method name=\"RequestAuthorization\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t</method>\n\t\t<method name=\"AuthorizeService\">\n\t\t\t<arg name=\"device\" direction=\"in\" type=\"o\"/>\n\t\t\t<arg name=\"uuid\" direction=\"in\" type=\"s\"/>\n\t\t</method>\n\t\t<method name=\"Cancel\">\n\t\t</method>\n\t</interface>\n</node>\n";
+ static guint _bt_agent_registration_id = 0;
+ static GHashTable *_pin_hash_table = NULL;
+--- a/src/lib/agent-helper.h   2016-12-12 09:18:08.000000000 +0100
++++ b/src/lib/agent-helper.h   2020-01-30 22:22:15.463751152 +0100
+@@ -35,7 +35,7 @@
+ #define AGENT_DBUS_INTERFACE "org.bluez.Agent1"
+ #define AGENT_PATH "/org/blueztools"
+-gboolean agent_need_unregister;
++extern gboolean agent_need_unregister;
+ void register_agent_callbacks(gboolean interactive_console, GHashTable *pin_dictonary, gpointer main_loop_object, GError **error);
+ void unregister_agent_callbacks(GError **error);
+@@ -44,4 +44,4 @@
+ }
+ #endif
+-#endif /* __AGENT_HELPER_H */
+\ Pas de fin de ligne à la fin du fichier
++#endif /* __AGENT_HELPER_H */