kde-frameworks/kwayland: Fix 5.64.0 build with Qt 5.14.0
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 25 Dec 2019 01:19:59 +0000 (02:19 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 25 Dec 2019 01:27:27 +0000 (02:27 +0100)
Upstream commit c4a49fbf2d5dd63659ed0c679ce180eda89a6d0d

Reported-by: m.manico@gmx.at
Closes: https://bugs.gentoo.org/703696
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-frameworks/kwayland/files/kwayland-5.64.0-qt-5.14.0.patch [new file with mode: 0644]
kde-frameworks/kwayland/kwayland-5.64.0.ebuild

diff --git a/kde-frameworks/kwayland/files/kwayland-5.64.0-qt-5.14.0.patch b/kde-frameworks/kwayland/files/kwayland-5.64.0-qt-5.14.0.patch
new file mode 100644 (file)
index 0000000..818e989
--- /dev/null
@@ -0,0 +1,24 @@
+From c4a49fbf2d5dd63659ed0c679ce180eda89a6d0d Mon Sep 17 00:00:00 2001
+From: Roman Gilg <subdiff@gmail.com>
+Date: Fri, 22 Nov 2019 15:26:23 +0100
+Subject: Add missing include for Qt 5.14 build
+
+---
+ src/server/xdgoutput_interface.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/server/xdgoutput_interface.cpp b/src/server/xdgoutput_interface.cpp
+index e32ccf9..b2b2cba 100644
+--- a/src/server/xdgoutput_interface.cpp
++++ b/src/server/xdgoutput_interface.cpp
+@@ -25,6 +25,8 @@ License along with this library.  If not, see <http://www.gnu.org/licenses/>.
+ #include <wayland-xdg-output-server-protocol.h>
++#include <QHash>
++
+ namespace KWayland
+ {
+ namespace Server
+-- 
+cgit v1.1
index b1e978e691f902d5d00688546570165882a78ac0..5a81ee17e71e9cec76f2ceb8e0d733f103e0a03d 100644 (file)
@@ -30,3 +30,5 @@ RDEPEND="${COMMON_DEPEND}
 
 # All failing, I guess we need a virtual wayland server
 RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.14.0.patch" )