dev-ml/zarith: Skip tests when not building native code, they require it. Bug #624292
authorAlexis Ballier <aballier@gentoo.org>
Sun, 9 Jul 2017 08:20:00 +0000 (10:20 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 9 Jul 2017 08:20:00 +0000 (10:20 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-ml/zarith/zarith-1.5.ebuild

index fcb766936ac40e21cc33c9b52fe5e0cccdeb7b6e..25bf4fad37010af4c53bb45f0cf0404158a9fcda 100644 (file)
@@ -37,7 +37,11 @@ src_compile() {
 }
 
 src_test() {
-       emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) tests
+       if use ocamlopt ; then
+               emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) tests
+       else
+               ewarn "Tests require USE=ocamlopt. Skipping them."
+       fi
 }
 
 src_install() {