sys-cluster/singularity: do not install bash-completion rules
authorMarek Szuba <marecki@gentoo.org>
Fri, 24 Apr 2020 14:22:56 +0000 (15:22 +0100)
committerMarek Szuba <marecki@gentoo.org>
Fri, 24 Apr 2020 14:25:42 +0000 (15:25 +0100)
Singularity installs them into the compatibility directory
(/etc/bash_completions.d), moreover they might be automatically generated
but they are still badly broken (confirmed to affect quite a few
commands which have got nothing to do with singularity).

With apologies to everyone who will end up emerge a revbump just to get
rid of a single shell file.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
sys-cluster/singularity/singularity-3.5.3-r1.ebuild [moved from sys-cluster/singularity/singularity-3.5.3.ebuild with 69% similarity]

similarity index 69%
rename from sys-cluster/singularity/singularity-3.5.3.ebuild
rename to sys-cluster/singularity/singularity-3.5.3-r1.ebuild
index 2a51a4074fcdf39459678ea88e975116f7744e7e..16834ae083a309bf7c4cef17ed81f18f0bbcedd1 100644 (file)
@@ -52,6 +52,16 @@ src_install() {
        emake DESTDIR="${ED}" -C builddir install
        keepdir /var/singularity/mnt/session
 
+       # As of version 3.5.3 this seems to be very much broken, affecting
+       # commands which have got nothing to do with singularity (example:
+       # completion on 'udisks mount -b /dev/' rejects all files from that
+       # directory other than 'autofs'). Moreover, this should go into
+       # $(get_bashcompdir) (from bash-completion-r1.eclass) rather than /etc.
+       # Hopefully temporary, which is why we delete this at install time
+       # instead of patching build scripts not to generate bash-completion
+       # data in the first place.
+       rm -rf "${ED}"/etc/bash_completion.d || die
+
        dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
        if use examples; then
                dodoc -r examples