xfce-base/garcon: Bump to 0.7.0
authorMichał Górny <mgorny@gentoo.org>
Sat, 4 Apr 2020 20:07:06 +0000 (22:07 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 4 Apr 2020 20:23:36 +0000 (22:23 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-base/garcon/Manifest
xfce-base/garcon/garcon-0.7.0.ebuild [new file with mode: 0644]

index 9cc47b2f05dcd2f1cc912ebfeb932459c5a42a4d..7dd1d465b7551f9eadf6f1b5b4f5a0a082f1d65e 100644 (file)
@@ -1 +1,2 @@
 DIST garcon-0.6.4.tar.bz2 519744 BLAKE2B 3d5e90d8a1159aac4eb2f2455978bbe1de99b523b5383037c021f3490800349bff1d6f5333853b08db34c9d18f3c5fc787f51927d94cfd2cd747e839b1529e38 SHA512 96a99eb163909ba411ca5928c3fc0a569a6d833fba92edcfa845eb90b56abb02e1428a2cbf61fc1c564f1659d51b24ce174e3864fcc987a37158703df0ac2510
+DIST garcon-0.7.0.tar.bz2 508624 BLAKE2B 592d0078f4141b600f6a60818ed86cdffe289fda0f691d48b0e1992ed83191ec075483d200d312b27bd5f02e6bb0daabafeaf47a4492f489eb1e8c2af3283be2 SHA512 e865f68fe595bbc22d023d72ce4663c75e837a6789eb2158747e2cb7420ea2bba06dfd660e1de20675b9f9057cb2a9c1dc24221de8be93882e9b29bffb1fce37
diff --git a/xfce-base/garcon/garcon-0.7.0.ebuild b/xfce-base/garcon/garcon-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..cc7ef74
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="https://docs.xfce.org/xfce/exo/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="-gtk2"
+
+RDEPEND=">=dev-libs/glib-2.30
+       >=x11-libs/gtk+-3.20:3
+       >=xfce-base/libxfce4util-4.12:=
+       gtk2? (
+               >=x11-libs/gtk+-2.24:2
+               <xfce-base/libxfce4ui-4.15:=[gtk2(+),gtk3(+)]
+       )
+       !gtk2? (
+               >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+       )"
+DEPEND="${RDEPEND}
+       dev-util/glib-utils
+       dev-util/gtk-doc-am
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README STATUS TODO )
+
+src_configure() {
+       local myconf=(
+               $(use_enable gtk2)
+               $(use_enable gtk2 libxfce4ui)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}