net-im/kadu: Update gtk icon cache, bug 630464. Remove custom handling of ccache...
authorMaciej Mrozowski <reavertm@gentoo.org>
Fri, 3 Nov 2017 02:10:25 +0000 (03:10 +0100)
committerMaciej Mrozowski <reavertm@gentoo.org>
Fri, 3 Nov 2017 02:10:44 +0000 (03:10 +0100)
Package-Manager: Portage-2.3.8, Repoman-2.3.4

net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch [new file with mode: 0644]
net-im/kadu/kadu-4.3-r1.ebuild

diff --git a/net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch b/net-im/kadu/files/kadu-4.3-do-not-force-ccache.patch
new file mode 100644 (file)
index 0000000..2511f3c
--- /dev/null
@@ -0,0 +1,17 @@
+diff -ruN kadu-4.3/CMakeLists.txt my/CMakeLists.txt
+--- kadu-4.3/CMakeLists.txt    2017-01-24 22:36:21.000000000 +0100
++++ my/CMakeLists.txt  2017-11-03 03:00:07.005162047 +0100
+@@ -75,13 +75,6 @@
+       endif ()
+ endif ()
+-## CCache is cool stuff to improve compilation time
+-find_program (CCACHE_FOUND ccache)
+-if (CCACHE_FOUND)
+-      set_property (GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
+-      set_property (GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
+-endif (CCACHE_FOUND)
+-
+ # Look above, DEBUG_ENABLED is always enabled in Debug configuration.
+ # Enable it in all configurations when ENABLE_DEVELOPER_BUILD is on.
+ if (ENABLE_DEVELOPER_BUILD)
index b3e45cf121e72694b43ac00a7bbd8463f1cb6dd3..a2dbc88c32f0ad9755873c6afc6a03b9a522520a 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI="6"
 
-inherit cmake-utils flag-o-matic
+inherit cmake-utils flag-o-matic gnome2-utils
 
 MY_P="${P/_/-}"
 
@@ -100,6 +100,10 @@ tabs
 word_fix
 '
 
+PATCHES=(
+       "${FILESDIR}/${PN}-4.3-do-not-force-ccache.patch"
+)
+
 src_configure() {
        # Filter out dangerous flags
        filter-flags -fno-rtti
@@ -128,3 +132,7 @@ src_configure() {
 
        cmake-utils_src_configure
 }
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}