dev-ros/qt_dotgraph: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 10:07:05 +0000 (12:07 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 10:12:07 +0000 (12:12 +0200)
Package-Manager: portage-2.2.21

dev-ros/qt_dotgraph/Manifest [new file with mode: 0644]
dev-ros/qt_dotgraph/metadata.xml [new file with mode: 0644]
dev-ros/qt_dotgraph/qt_dotgraph-0.2.29.ebuild [new file with mode: 0644]
dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/qt_dotgraph/Manifest b/dev-ros/qt_dotgraph/Manifest
new file mode 100644 (file)
index 0000000..85ca418
--- /dev/null
@@ -0,0 +1 @@
+DIST qt_gui_core-0.2.29.tar.gz 85881 SHA256 7c51b4fd7e795e37e3f8a4b691a5e520466105fdddbc85e194c10c608fe7448c SHA512 958526a3bd76070e121d75a82c589894aef980870091cb853802fcb60328b54cbc95ee0c9eececa18e24608808cca2c722c5699b662c2a578f150995171d71db WHIRLPOOL f83328ce59fd9cd8db5a066f1a2a93bde54b28268891b18cf73b31d5584b0dc7f932350a39e729c97be3bc3b6780422dd2538321f29b0acd13d06387e0054975
diff --git a/dev-ros/qt_dotgraph/metadata.xml b/dev-ros/qt_dotgraph/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/qt_dotgraph/qt_dotgraph-0.2.29.ebuild b/dev-ros/qt_dotgraph/qt_dotgraph-0.2.29.ebuild
new file mode 100644 (file)
index 0000000..c76b5bc
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helpers to work with dot graphs"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       media-gfx/pydot[${PYTHON_USEDEP}]
+       dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/pygraphviz[${PYTHON_USEDEP}]
+       )"
diff --git a/dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild b/dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild
new file mode 100644 (file)
index 0000000..c76b5bc
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helpers to work with dot graphs"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       media-gfx/pydot[${PYTHON_USEDEP}]
+       dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/pygraphviz[${PYTHON_USEDEP}]
+       )"