sci-mathematics/arb: fixed for linking with PIE
authorSébastien Fabbro <bicatali@gentoo.org>
Fri, 28 Jul 2017 21:41:41 +0000 (21:41 +0000)
committerSébastien Fabbro <bicatali@gentoo.org>
Fri, 28 Jul 2017 21:42:01 +0000 (21:42 +0000)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

sci-mathematics/arb/arb-2.11.1-r1.ebuild [moved from sci-mathematics/arb/arb-2.11.1.ebuild with 92% similarity]
sci-mathematics/arb/files/arb-2.11.1-pie-ftbs.patch [new file with mode: 0644]

similarity index 92%
rename from sci-mathematics/arb/arb-2.11.1.ebuild
rename to sci-mathematics/arb/arb-2.11.1-r1.ebuild
index bea3d8d89eceef63bbb6fcb0690bbb9c2f33edab..88e262a3d9fd5a45cf657352a4d323c1948d72e4 100644 (file)
@@ -21,6 +21,8 @@ RDEPEND="
 "
 DEPEND="${RDEPEND}"
 
+PATCHES=( "${FILESDIR}"/${P}-pie-ftbs.patch )
+
 src_configure() {
        # Not an autoconf configure script.
        # Note that it appears to have been cloned from the flint configure script
@@ -31,7 +33,8 @@ src_configure() {
                --with-flint="${EPREFIX}/usr" \
                --with-gmp="${EPREFIX}/usr" \
                --with-mpfr="${EPREFIX}/usr" \
-               $(use_enable static-libs static) || die
+               $(use_enable static-libs static) \
+               CFLAGS="${CPPFLAGS} ${CFLAGS}" || die
 }
 
 src_compile() {
diff --git a/sci-mathematics/arb/files/arb-2.11.1-pie-ftbs.patch b/sci-mathematics/arb/files/arb-2.11.1-pie-ftbs.patch
new file mode 100644 (file)
index 0000000..b2db6b2
--- /dev/null
@@ -0,0 +1,17 @@
+Description: Use -r instead of -Wl,-r to fix FTBFS with PIE enabled
+Author: Logan Rosen
+Forwarded: yes
+
+diff --git a/Makefile.subdirs b/Makefile.subdirs
+index 3dc757d..f0ec923 100644
+--- a/Makefile.subdirs
++++ b/Makefile.subdirs
+@@ -52,7 +52,7 @@ $(BUILD_DIR)/$(MOD_DIR)_%.o: %.c
+       $(QUIET_CC) $(CC) $(CFLAGS) $(INCS) -c $< -o $@ -MMD -MP -MF "$(BUILD_DIR)/$(MOD_DIR)_$*.d" -MT "$(BUILD_DIR)/$(MOD_DIR)_$*.d" -MT "$@"
+ $(MOD_LOBJ): $(LOBJS)
+-      $(QUIET_CC) $(CC) $(ABI_FLAG) -Wl,-r $^ -o $@ -nostdlib
++      $(QUIET_CC) $(CC) $(ABI_FLAG) -r $^ -o $@ -nostdlib
+ -include $(LOBJS:.lo=.d)