net-misc/chrony: Version 4.0_pre1
authorJeroen Roovers <jer@gentoo.org>
Fri, 20 Mar 2020 09:40:31 +0000 (10:40 +0100)
committerJeroen Roovers <jer@gentoo.org>
Fri, 20 Mar 2020 09:41:07 +0000 (10:41 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/chrony/Manifest
net-misc/chrony/chrony-4.0_pre1.ebuild [new file with mode: 0644]
net-misc/chrony/metadata.xml

index 696b9d476e0c36d8636159b1835091720ffeaf65..f192425d2e5b7e01a69748fd2cf726eacbc9316b 100644 (file)
@@ -1 +1,2 @@
 DIST chrony-3.5.tar.gz 458226 BLAKE2B 611f21e36c6e745208e00eba988519fcd912c6c0c3518c953591f43224dc3da79f627027a6cd4bf9c4227e9f8659a69adbdb634252ff3920d2ef677e32012456 SHA512 c4f6376a44d71b6ac2b6d86e3d6fb4348642faeef7f3f3a4d6431627b5645efcc868b005cc398c8292bc3b63a1161fbd1a042c6ac2a0595843f908fe32eed90c
+DIST chrony-4.0-pre1.tar.gz 506735 BLAKE2B f06afaa0ae653b549760e3b8e2e8a33f70450895cda99773e49fa70358bea637434fd18e55a73e53a2f8ccd92ae9ee4555dcea98afbcae9317b122bf1e1cb5b3 SHA512 0b850d57fded23ac3cfe5907edb2a2b8441397a37575ce3b4af54f3b8f28ae7ae74f92926f619e4907a24d9bc10bb6b416bfe3ccc9d567720e3511d7f9513c59
diff --git a/net-misc/chrony/chrony-4.0_pre1.ebuild b/net-misc/chrony/chrony-4.0_pre1.ebuild
new file mode 100644 (file)
index 0000000..3f2cb33
--- /dev/null
@@ -0,0 +1,130 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="https://chrony.tuxfamily.org/"
+SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="
+       +adns caps +cmdmon html ipv6 libedit +nettle +ntp +phc pps readline +refclock +rtc
+       seccomp +sechash selinux
+"
+REQUIRED_USE="
+       ?? ( libedit readline )
+       sechash? ( nettle )
+"
+
+CDEPEND="
+       caps? ( sys-libs/libcap )
+       libedit? ( dev-libs/libedit )
+       nettle? ( dev-libs/nettle )
+       readline? ( >=sys-libs/readline-4.1-r4:= )
+       seccomp? ( sys-libs/libseccomp )
+"
+DEPEND="
+       ${CDEPEND}
+       html? ( dev-ruby/asciidoctor )
+       pps? ( net-misc/pps-tools )
+"
+RDEPEND="
+       ${CDEPEND}
+       selinux? ( sec-policy/selinux-chronyd )
+"
+
+RESTRICT=test
+
+S="${WORKDIR}/${P/_/-}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.5-pool-vendor-gentoo.patch
+       "${FILESDIR}"/${PN}-3.5-systemd-gentoo.patch
+)
+
+src_prepare() {
+       default
+       sed -i \
+               -e 's:/etc/chrony\.conf:/etc/chrony/chrony.conf:g' \
+               doc/* examples/* || die
+}
+
+src_configure() {
+       tc-export CC
+
+       local CHRONY_EDITLINE
+       # ./configure legend:
+       # --disable-readline : disable line editing entirely
+       # --without-readline : do not use sys-libs/readline (enabled by default)
+       # --without-editline : do not use dev-libs/libedit (enabled by default)
+       if ! use readline && ! use libedit; then
+               CHRONY_EDITLINE='--disable-readline'
+       else
+               CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
+               CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
+       fi
+
+       # not an autotools generated script
+       local myconf=(
+               $(use_enable seccomp scfilter)
+               $(usex adns '' --disable-asyncdns)
+               $(usex caps '' --disable-linuxcaps)
+               $(usex cmdmon '' --disable-cmdmon)
+               $(usex ipv6 '' --disable-ipv6)
+               $(usex nettle '' --without-nettle)
+               $(usex ntp '' --disable-ntp)
+               $(usex phc '' --disable-phc)
+               $(usex pps '' --disable-pps)
+               $(usex refclock '' --disable-refclock)
+               $(usex rtc '' --disable-rtc)
+               $(usex sechash '' --disable-sechash)
+               ${CHRONY_EDITLINE}
+               ${EXTRA_ECONF}
+               --chronysockdir="${EPREFIX}/run/chrony"
+               --docdir="${EPREFIX}/usr/share/doc/${PF}"
+               --mandir="${EPREFIX}/usr/share/man"
+               --prefix="${EPREFIX}/usr"
+               --sysconfdir="${EPREFIX}/etc/chrony"
+               --with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
+               --without-nss
+               --without-tomcrypt
+       )
+
+       # print the ./configure call to aid in future debugging
+       echo bash ./configure "${myconf[@]}" >&2
+       bash ./configure "${myconf[@]}" || die
+}
+
+src_compile() {
+       emake all docs $(usex html '' 'ADOC=true')
+}
+
+src_install() {
+       default
+
+       newinitd "${FILESDIR}"/chronyd.init-r2 chronyd
+       newconfd "${FILESDIR}"/chronyd.conf chronyd
+
+       insinto /etc/${PN}
+       newins examples/chrony.conf.example1 chrony.conf
+
+       docinto examples
+       dodoc examples/*.example*
+
+       if use html; then
+               docinto html
+               dodoc doc/*.html
+       fi
+
+       keepdir /var/{lib,log}/chrony
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
+
+       systemd_dounit examples/{chronyd,chrony-wait}.service
+       systemd_enable_ntpunit 50-chrony chronyd.service
+}
index 290f9476459b94d60d0697ad29bc3901ced62be9..70ff1db236380ab034f56a8bd987a2e2362e036b 100644 (file)
@@ -21,10 +21,12 @@ Chrony はコンピュータのシステム・クロックの精度を保つた
 <flag name="adns">Support for asynchronous DNS</flag>
 <flag name="cmdmon">Support for command and monitoring</flag>
 <flag name="html">Install HTML documentation</flag>
+<flag name="nettle">Use <pkg>dev-libs/nettle</pkg> for hash functions</flag>
 <flag name="ntp">Support for the Network Time Protocol (NTP)</flag>
 <flag name="phc">Support for the PTP (Precision Time Protocol) Hardware Clock (PHC) interface</flag>
 <flag name="pps">Support for the Linux Pulse Per Second (PPS) interface</flag>
 <flag name="refclock">Support for reference clocks</flag>
 <flag name="rtc">Support for the Linux Real Time Clock interface</flag>
+<flag name="sechash">Enable support for hashes other than MD5</flag>
 </use>
 </pkgmetadata>