mail-client/trojita: EAPI-7 bump, use cmake.eclass, xdg.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 19 Apr 2020 11:29:22 +0000 (13:29 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 19 Apr 2020 12:01:49 +0000 (14:01 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
mail-client/trojita/trojita-0.7-r2.ebuild
mail-client/trojita/trojita-9999.ebuild

index a5904f016e3ab8c711fb76740b30055d57cd60a2..f2648fcf92b837ed17019c0a80410a67bc19dc66 100644 (file)
@@ -1,26 +1,31 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-EGIT_REPO_URI="https://anongit.kde.org/${PN}.git"
-inherit cmake-utils gnome2-utils virtualx xdg-utils
-[[ ${PV} == 9999 ]] && inherit git-r3
-
-DESCRIPTION="A Qt IMAP e-mail client"
-HOMEPAGE="http://trojita.flaska.net/"
-if [[ ${PV} != 9999 ]]; then
+if [[ ${PV} = *9999* ]]; then
+       EGIT_REPO_URI="https://anongit.kde.org/${PN}.git"
+       inherit git-r3
+else
        SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
        KEYWORDS="amd64 x86"
 fi
+inherit cmake virtualx xdg
+
+DESCRIPTION="A Qt IMAP e-mail client"
+HOMEPAGE="http://trojita.flaska.net/"
 
 LICENSE="|| ( GPL-2 GPL-3 )"
 SLOT="0"
 IUSE="+crypt +dbus debug +password test +zlib"
-RESTRICT="!test? ( test )"
 
 REQUIRED_USE="password? ( dbus )"
+RESTRICT="!test? ( test )"
 
+BDEPEND="
+       dev-qt/linguist-tools:5
+       zlib? ( virtual/pkgconfig )
+"
 RDEPEND="
        dev-qt/qtcore:5
        dev-qt/qtgui:5
@@ -38,9 +43,7 @@ RDEPEND="
        zlib? ( sys-libs/zlib )
 "
 DEPEND="${RDEPEND}
-       dev-qt/linguist-tools:5
        test? ( dev-qt/qttest:5 )
-       zlib? ( virtual/pkgconfig )
 "
 
 DOCS=( README LICENSE )
@@ -53,11 +56,11 @@ PATCHES=(
 )
 
 src_prepare() {
-       cmake-utils_src_prepare
+       cmake_src_prepare
 
        # the build system is taking a look at `git describe ... --dirty` and
        # gentoo's modifications to CMakeLists.txt break these
-       sed -i "s/--dirty//" "${S}/cmake/TrojitaVersion.cmake" || die "Cannot fix the version check"
+       sed -e "s/--dirty//" -i cmake/TrojitaVersion.cmake || die "Cannot fix the version check"
 }
 
 src_configure() {
@@ -71,23 +74,9 @@ src_configure() {
                -DWITH_ZLIB=$(usex zlib)
        )
 
-       cmake-utils_src_configure
+       cmake_src_configure
 }
 
 src_test() {
-       virtx cmake-utils_src_test
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       xdg_desktop_database_update
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       xdg_desktop_database_update
-       gnome2_icon_cache_update
+       virtx cmake_src_test
 }
index a6f81504d4eb3a3acc9b74d0d92019ad54e69c00..672e67f6cd69795d77728f73dd0d6845fd66c71b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -18,9 +18,9 @@ HOMEPAGE="http://trojita.flaska.net/"
 LICENSE="|| ( GPL-2 GPL-3 )"
 SLOT="0"
 IUSE="+crypt +dbus debug +password pim +spell test +zlib"
-RESTRICT="!test? ( test )"
 
 REQUIRED_USE="password? ( dbus )"
+RESTRICT="!test? ( test )"
 
 BDEPEND="
        dev-qt/linguist-tools:5