net-p2p/transmission: disable cmake warning for subprojects
authorMike Gilbert <floppym@gentoo.org>
Sun, 24 May 2020 02:30:02 +0000 (22:30 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sun, 24 May 2020 02:33:18 +0000 (22:33 -0400)
Closes: https://bugs.gentoo.org/724792
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
net-p2p/transmission/files/cmake-unused-command-line.patch [new file with mode: 0644]
net-p2p/transmission/transmission-3.00.ebuild

diff --git a/net-p2p/transmission/files/cmake-unused-command-line.patch b/net-p2p/transmission/files/cmake-unused-command-line.patch
new file mode 100644 (file)
index 0000000..6e0af5d
--- /dev/null
@@ -0,0 +1,21 @@
+From 63b8fd6391cd30bb45e1c9432f69c43ade9bb7ea Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sat, 23 May 2020 22:25:42 -0400
+Subject: [PATCH] Do not warn about unused command line options
+
+---
+ cmake/TrMacros.cmake | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cmake/TrMacros.cmake b/cmake/TrMacros.cmake
+index 5e439126f..674b2ede0 100644
+--- a/cmake/TrMacros.cmake
++++ b/cmake/TrMacros.cmake
+@@ -95,6 +95,7 @@ macro(tr_add_external_auto_library ID DIRNAME LIBNAME)
+             PREFIX "${${ID}_PREFIX}"
+             CMAKE_ARGS
+                 -Wno-dev # We don't want to be warned over unused variables
++              --no-warn-unused-cli
+                 "-DCMAKE_TOOLCHAIN_FILE:PATH=${CMAKE_TOOLCHAIN_FILE}"
+                 "-DCMAKE_USER_MAKE_RULES_OVERRIDE=${CMAKE_USER_MAKE_RULES_OVERRIDE}"
+                 "-DCMAKE_C_FLAGS:STRING=${CMAKE_C_FLAGS}"
index 04a6fdf452942ea464906e4415c7feb589ab8d16..3cfd308eb560627e636ffc2cdfb685b73e38a169 100644 (file)
@@ -84,6 +84,10 @@ RDEPEND="${COMMON_DEPEND}
        ${ACCT_DEPEND}
 "
 
+PATCHES=(
+       "${FILESDIR}"/cmake-unused-command-line.patch
+)
+
 src_configure() {
        local mycmakeargs=(
                -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}