dev-util/pycharm-community: allow bundled jdk on demand
authorMikle Kolyada <zlogene@gentoo.org>
Wed, 13 May 2020 10:10:15 +0000 (13:10 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Wed, 13 May 2020 10:10:58 +0000 (13:10 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-util/pycharm-community/metadata.xml
dev-util/pycharm-community/pycharm-community-2020.1.ebuild

index d21de2d9f07be867f877c1c1b923decf4b631b09..c405595aa1a25a7618d390ff5849be974a72cf44 100644 (file)
@@ -5,4 +5,7 @@
        <name>Mikle Kolyada</name>
        <email>zlogene@gentoo.org</email>
 </maintainer>
+<use>
+       <flag name="bundled-jdk">Use bundled jdk</flag>
+</use>
 </pkgmetadata>
index 0600c9803a8d3703fcbf06aafaa02c5cca6efaec..f8be402a51b3a44f3149af4df31210fa68e7263a 100644 (file)
@@ -12,8 +12,9 @@ SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
 LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
+IUSE="+bundled-jdk"
 
-RDEPEND=">=virtual/jre-1.8
+RDEPEND="!bundled-jdk? ( >=virtual/jre-1.8 )
        dev-libs/libdbusmenu
        dev-python/pip"
 
@@ -25,16 +26,16 @@ QA_PREBUILT="opt/${PN}/bin/fsnotifier
 
 MY_PN=${PN/-community/}
 
-src_prepare() {
-       default
-
-       rm -rf jre || die
-}
-
 src_install() {
        insinto /opt/${PN}
        doins -r *
 
+       if use bundled-jdk; then
+               fperms -R a+x /opt/pycharm-community/jbr/bin/
+       else
+               rm -r "${D}"/opt/pycharm-community/jbr/ || die
+       fi
+
        fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
 
        dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}