dev-ros/message_filters: upstream boost fix
authorAlexis Ballier <aballier@gentoo.org>
Sat, 20 Jul 2019 11:22:25 +0000 (13:22 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 20 Jul 2019 11:23:16 +0000 (13:23 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/message_filters/files/boost.patch [new file with mode: 0644]
dev-ros/message_filters/message_filters-1.14.3-r1.ebuild [moved from dev-ros/message_filters/message_filters-1.14.3.ebuild with 92% similarity]

diff --git a/dev-ros/message_filters/files/boost.patch b/dev-ros/message_filters/files/boost.patch
new file mode 100644 (file)
index 0000000..1acc778
--- /dev/null
@@ -0,0 +1,26 @@
+commit 41f18edc9f2f0b1ef304ea25f148bd56a6bf3d70
+Author: Maarten de Vries <maarten@de-vri.es>
+Date:   Thu Jan 31 00:58:29 2019 +0100
+
+    Remove signals from find_package(Boost COMPONENTS ...) (#1580)
+    
+    The packages use signals2, not signals. Only boost libraries with
+    compiled code should be passed to find_package(Boost COMPONENTS ...),
+    and the signals2 library has always been header only.
+    
+    Boost 1.69 has removed the deprecated signals library, so the otherwise
+    useless but harmless `signals` component now breaks the build.
+
+diff --git a/utilities/message_filters/CMakeLists.txt b/utilities/message_filters/CMakeLists.txt
+index 5694ac57e..d2b1477ad 100644
+--- a/utilities/message_filters/CMakeLists.txt
++++ b/utilities/message_filters/CMakeLists.txt
+@@ -13,7 +13,7 @@ catkin_package(
+ )
+ catkin_python_setup()
+-find_package(Boost REQUIRED COMPONENTS signals thread)
++find_package(Boost REQUIRED COMPONENTS thread)
+ include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+ link_directories(${catkin_LIBRARY_DIRS})
similarity index 92%
rename from dev-ros/message_filters/message_filters-1.14.3.ebuild
rename to dev-ros/message_filters/message_filters-1.14.3-r1.ebuild
index ec237f43cd55614b3d5c028ceccb9a5e7801cb8b..48aa4d167295b0459acae735a0d2095c1bc49249 100644 (file)
@@ -29,4 +29,4 @@ DEPEND="${RDEPEND}
                dev-cpp/gtest
                dev-python/nose[${PYTHON_USEDEP}]
        )"
-PATCHES=( "${FILESDIR}/tests.patch" )
+PATCHES=( "${FILESDIR}/tests.patch" "${FILESDIR}/boost.patch" )