-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils toolchain-funcs cmake-utils
+inherit cmake-utils toolchain-funcs
DESCRIPTION="Extract closed captioning subtitles from video to SRT"
-HOMEPAGE="http://ccextractor.sourceforge.net/"
+HOMEPAGE="https://www.ccextractor.org/"
SRC_URI="mirror://sourceforge/ccextractor/${PN}-src-nowin.${PV}.zip"
LICENSE="GPL-2"
S="${WORKDIR}/${PN}/src"
-PATCHES=(
- "${FILESDIR}/${P}-makefile.patch"
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-}
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
---- ccextractor/src/CMakeLists.txt.orig 2017-07-25 12:22:29.294144514 -0600
-+++ ccextractor/src/CMakeLists.txt 2017-07-25 12:23:33.979149436 -0600
+--- a/CMakeLists.txt 2017-07-25 12:22:29.294144514 -0600
++++ b/CMakeLists.txt 2017-07-25 12:23:33.979149436 -0600
@@ -25,14 +25,13 @@
include_directories ("${PROJECT_SOURCE_DIR}/protobuf-c/")
include_directories ("${PROJECT_SOURCE_DIR}/zvbi")
########################################################
# Build using FFmpeg libraries
---- ccextractor/src/lib_ccx/CMakeLists.txt.orig 2017-07-25 12:32:32.803190443 -0600
-+++ ccextractor/src/lib_ccx/CMakeLists.txt 2017-07-25 12:25:40.819159089 -0600
+--- a/lib_ccx/CMakeLists.txt 2017-07-25 12:32:32.803190443 -0600
++++ b/lib_ccx/CMakeLists.txt 2017-07-25 12:25:40.819159089 -0600
@@ -1,6 +1,6 @@
cmake_policy (SET CMP0037 NEW)