media-video/ccextractor: EAPI-6 bump, HOMEPAGE, cleanup
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 26 Aug 2018 07:26:51 +0000 (09:26 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 26 Aug 2018 08:51:25 +0000 (10:51 +0200)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

media-video/ccextractor/ccextractor-0.85-r1.ebuild
media-video/ccextractor/files/ccextractor-0.85-cmake.patch [moved from media-video/ccextractor/files/ccextractor-0.85-makefile.patch with 89% similarity]

index 35c0f63e14fe82769948332a564014f83a864414..aad1f505d1f3a6acb6a86b5e193210e05f721309 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-inherit eutils toolchain-funcs cmake-utils
+inherit cmake-utils toolchain-funcs
 
 DESCRIPTION="Extract closed captioning subtitles from video to SRT"
-HOMEPAGE="http://ccextractor.sourceforge.net/"
+HOMEPAGE="https://www.ccextractor.org/"
 SRC_URI="mirror://sourceforge/ccextractor/${PN}-src-nowin.${PV}.zip"
 
 LICENSE="GPL-2"
@@ -24,10 +24,4 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}/${PN}/src"
 
-PATCHES=(
-       "${FILESDIR}/${P}-makefile.patch"
-)
-
-src_prepare() {
-       cmake-utils_src_prepare
-}
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
similarity index 89%
rename from media-video/ccextractor/files/ccextractor-0.85-makefile.patch
rename to media-video/ccextractor/files/ccextractor-0.85-cmake.patch
index 6937869180dedf4b10d4c14ed99ff7878d04807f..2fcf6cfee4b0afa34cdebb2cd20f4f15b0d06a1b 100644 (file)
@@ -1,5 +1,5 @@
---- ccextractor/src/CMakeLists.txt.orig        2017-07-25 12:22:29.294144514 -0600
-+++ ccextractor/src/CMakeLists.txt     2017-07-25 12:23:33.979149436 -0600
+--- a/CMakeLists.txt   2017-07-25 12:22:29.294144514 -0600
++++ b/CMakeLists.txt   2017-07-25 12:23:33.979149436 -0600
 @@ -25,14 +25,13 @@
  include_directories ("${PROJECT_SOURCE_DIR}/protobuf-c/")
  include_directories ("${PROJECT_SOURCE_DIR}/zvbi")
@@ -43,8 +43,8 @@
  
  ########################################################
  # Build using FFmpeg libraries
---- ccextractor/src/lib_ccx/CMakeLists.txt.orig        2017-07-25 12:32:32.803190443 -0600
-+++ ccextractor/src/lib_ccx/CMakeLists.txt     2017-07-25 12:25:40.819159089 -0600
+--- a/lib_ccx/CMakeLists.txt   2017-07-25 12:32:32.803190443 -0600
++++ b/lib_ccx/CMakeLists.txt   2017-07-25 12:25:40.819159089 -0600
 @@ -1,6 +1,6 @@
  cmake_policy (SET CMP0037 NEW)