dev-python/bleach: Unbundle html5lib
authorMichał Górny <mgorny@gentoo.org>
Sat, 4 Apr 2020 15:16:22 +0000 (17:16 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 4 Apr 2020 17:04:13 +0000 (19:04 +0200)
Closes: https://bugs.gentoo.org/716166
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/bleach/bleach-3.1.4-r1.ebuild [moved from dev-python/bleach/bleach-3.1.4.ebuild with 70% similarity]

similarity index 70%
rename from dev-python/bleach/bleach-3.1.4.ebuild
rename to dev-python/bleach/bleach-3.1.4-r1.ebuild
index 5a78157e2d612919ed8809791553981e15d6399a..d80fe336be4abfe71d9efd1e7cc9a6e36d76de99 100644 (file)
@@ -16,8 +16,18 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
 IUSE="test"
 
 RDEPEND="
+       >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
        dev-python/webencodings[${PYTHON_USEDEP}]
 "
 
 distutils_enable_tests pytest
+
+src_prepare() {
+       # unbundle unpatched broken html5lib
+       rm -r bleach/_vendor || die
+       sed -i -e 's:bleach\._vendor\.::' \
+               bleach/html5lib_shim.py tests/test_clean.py || die
+
+       distutils-r1_src_prepare
+}