lxqt-base/lxqt-notificationd: add version 0.15.0
authorJimi Huotari <chiitoo@gentoo.org>
Mon, 27 Apr 2020 18:46:48 +0000 (21:46 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 May 2020 23:28:30 +0000 (01:28 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
lxqt-base/lxqt-notificationd/Manifest
lxqt-base/lxqt-notificationd/lxqt-notificationd-0.15.0.ebuild [new file with mode: 0644]

index 7930cc9bfd03b2db40d3728517f07e24a7d51516..a5efffae82c9f6096979b7fd5b447dd50aa6ae70 100644 (file)
@@ -1 +1,2 @@
 DIST lxqt-notificationd-0.14.1.tar.xz 47356 BLAKE2B b80febe059a17e30df4abb81e6d63271b8955211474d80853dc54ea65112081160bf270766654498b50c78c58df4444682e1e9b9cac800c4afb294fdb2fdbaeb SHA512 dcd1892ff66d6beb5c8953c6731f798a59272365fb7439277732b145cc9e6479314415481d9e8aae9fd670d779011c3d7bb3874b05a67cfad2a722f467866795
+DIST lxqt-notificationd-0.15.0.tar.xz 49068 BLAKE2B 00277a1ecb75a7591ad4d74156889f9fceec1f81b752f2d6dc10bc77a8dbe8406df88ff4b768dfa42efa3b50048fd757b648766fa7131f7e11b5314fc9718a9e SHA512 0febe3ff61caaf4303e3853df6bc494ce8eb4a931e6d8600a2e38c07317ecadbe3d7060ac234d139326a726c43ac555153dde6b2d4d05e95ab357873457c9632
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.15.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.15.0.ebuild
new file mode 100644 (file)
index 0000000..a78ba27
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+       >=dev-util/lxqt-build-tools-0.7.0
+"
+DEPEND="
+       >=dev-libs/libqtxdg-3.3.1
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       kde-frameworks/kwindowsystem:5
+       =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}
+       !lxqt-base/lxqt-l10n
+"