dev-python/acme: new package, dependency for acmebot
authorRobin H. Johnson <robbat2@gentoo.org>
Sat, 20 Apr 2019 06:16:22 +0000 (23:16 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Sat, 20 Apr 2019 06:16:32 +0000 (23:16 -0700)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
dev-python/acme/Manifest [new file with mode: 0644]
dev-python/acme/acme-0.33.1.ebuild [new file with mode: 0644]
dev-python/acme/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/acme/Manifest b/dev-python/acme/Manifest
new file mode 100644 (file)
index 0000000..b9c51c4
--- /dev/null
@@ -0,0 +1 @@
+DIST acme-0.33.1.tar.gz 86232 BLAKE2B 1b0145545fde66c8b897e81b78e7bb86f5473710a37b27575819ae48590a54dcbf93004be030d841edc3c6682641155c0ad892bd459a8e1773f15f5480411f47 SHA512 17837af68a9edd410b6a036f7ba1d92a486eab235cdeb6941f9ee210eb7acc660acf8804f25640f1395f51b42be1892ac1701425301365e43d67f78520664e07
diff --git a/dev-python/acme/acme-0.33.1.ebuild b/dev-python/acme/acme-0.33.1.ebuild
new file mode 100644 (file)
index 0000000..a62239e
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python2_7 python3_{4,5,6})
+
+inherit distutils-r1
+
+DESCRIPTION="ACME protocol implementation in Python"
+HOMEPAGE="https://github.com/letsencrypt/letsencrypt
+               https://github.com/certbot/certbot/tree/master/acme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+       >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+       >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+       >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
+       dev-python/pyrfc3339[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.6.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       "
+DEPEND="
+       ${CDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+       )
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-xdist[${PYTHON_USEDEP}]
+               dev-python/tox[${PYTHON_USEDEP}]
+       )"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+       use doc && esetup.py build_sphinx
+}
+
+python_test() {
+       py.test || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+
+       distutils-r1_python_install_all
+}
diff --git a/dev-python/acme/metadata.xml b/dev-python/acme/metadata.xml
new file mode 100644 (file)
index 0000000..5d4196c
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>robbat2@gentoo.org</email>
+       </maintainer>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+               <name>Python</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="pypi">acme</remote-id>
+               <remote-id type="github">letsencrypt/letsencrypt</remote-id>
+       </upstream>
+</pkgmetadata>