sys-apps/consolation: New package
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 11 Oct 2019 21:24:55 +0000 (14:24 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 11 Oct 2019 21:25:22 +0000 (14:25 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
sys-apps/consolation/Manifest [new file with mode: 0644]
sys-apps/consolation/consolation-0.0.7.ebuild [new file with mode: 0644]
sys-apps/consolation/files/consolation-0.0.7-makefile.patch [new file with mode: 0644]
sys-apps/consolation/files/consolation-confd [new file with mode: 0644]
sys-apps/consolation/files/consolation-initd [new file with mode: 0644]
sys-apps/consolation/metadata.xml [new file with mode: 0644]

diff --git a/sys-apps/consolation/Manifest b/sys-apps/consolation/Manifest
new file mode 100644 (file)
index 0000000..821b381
--- /dev/null
@@ -0,0 +1 @@
+DIST consolation-consolation-0.0.7.tar.gz 11811 BLAKE2B 7d100a49b766a250eac622785b2f310bef4801a16eac665d7ce5ede249c533c3b948f039d7215e9c55d711f3d2b575972640357fa0e34c114705bef389cdc60f SHA512 dfe101c5198fd57e51e51339a031b5b7216a6df26e039457303f5269b78a98e3c80902c303fd82f26158760543ffa22d1a0c1e73c794c717e0bdd6f1d298a72c
diff --git a/sys-apps/consolation/consolation-0.0.7.ebuild b/sys-apps/consolation/consolation-0.0.7.ebuild
new file mode 100644 (file)
index 0000000..b616cd1
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd autotools
+
+DESCRIPTION="libinput based console mouse daemon"
+HOMEPAGE="https://salsa.debian.org/consolation-team/consolation"
+SRC_URI="https://salsa.debian.org/consolation-team/${PN}/-/archive/${P}/${PN}-${P}.tar.gz"
+
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libinput:=
+       virtual/libudev:=
+       dev-libs/libevdev:="
+RDEPEND="${DEPEND}"
+BDEPEND="sys-apps/help2man"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=(
+       "${FILESDIR}/consolation-0.0.7-makefile.patch"
+)
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_install() {
+       default
+
+       newinitd "${FILESDIR}/${PN}-initd" ${PN}
+       newconfd "${FILESDIR}/${PN}-confd" ${PN}
+
+       systemd_dounit consolation.service
+}
diff --git a/sys-apps/consolation/files/consolation-0.0.7-makefile.patch b/sys-apps/consolation/files/consolation-0.0.7-makefile.patch
new file mode 100644 (file)
index 0000000..b699edc
--- /dev/null
@@ -0,0 +1,25 @@
+diff --git a/Makefile.am b/Makefile.am
+index c577a9a..8a0e07f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,7 +5,7 @@ CLEANFILES = consolation.service
+ all: consolation.8 consolation.service
+-consolation.8: README src/shared.c $(top_srcdir)/configure.ac
++consolation.8: src/consolation-recursive README src/shared.c $(top_srcdir)/configure.ac
+       help2man --no-info --source=Debian --section=8 --include=README \
+       src/consolation \
+       | sed -e 's,\\fB,.TP\n\\fB,g' > consolation.8.new   \
+diff --git a/configure.ac b/configure.ac
+index 10bf054..25bdebc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -5,6 +5,7 @@ AC_INIT([consolation], [0.0.7])
+ AC_CONFIG_AUX_DIR(config)
+ AM_INIT_AUTOMAKE([1.11 foreign no-dist-gzip dist-xz])
++AM_EXTRA_RECURSIVE_TARGETS([src/consolation])
+ AM_CONFIG_HEADER(src/config.h)
+ # Check for programs
diff --git a/sys-apps/consolation/files/consolation-confd b/sys-apps/consolation/files/consolation-confd
new file mode 100644 (file)
index 0000000..fd03ae3
--- /dev/null
@@ -0,0 +1,4 @@
+# /etc/conf.d/consolation
+
+# arguments to pass to consolation
+#consolation_args=""
diff --git a/sys-apps/consolation/files/consolation-initd b/sys-apps/consolation/files/consolation-initd
new file mode 100644 (file)
index 0000000..c9252a8
--- /dev/null
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+# Copyright 2019 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+name="consolation daemon"
+description=""
+command=/usr/sbin/consolation
+command_args="${consolation_args}"
+
+depend() {
+       need udev
+}
diff --git a/sys-apps/consolation/metadata.xml b/sys-apps/consolation/metadata.xml
new file mode 100644 (file)
index 0000000..56cae16
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>chutzpah@gentoo.org</email>
+    <name>Patrick McLean</name>
+  </maintainer>
+</pkgmetadata>