app-portage/nattka: Bump to 0.1.2
authorMichał Górny <mgorny@gentoo.org>
Sat, 11 Apr 2020 06:35:14 +0000 (08:35 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 11 Apr 2020 07:49:14 +0000 (09:49 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/nattka/Manifest
app-portage/nattka/nattka-0.1.2.ebuild [new file with mode: 0644]

index a975ca943a20485e5188f3807d2df069ab5d8d19..bb16d70a08af27f40fb83a711e0aa76b1b04c131 100644 (file)
@@ -1,2 +1,3 @@
 DIST nattka-0.1.1.tar.gz 73700 BLAKE2B 15918e2e923bd8f1c81b5496ffedcada785c2622e8d00fa57424543ba35745c76bcfbe60ccec4242e87f964dd93aa383f13d02e56c3328e8634680d5e7206293 SHA512 8a73f11cb432f3dcb2313594972045908745892ee96a54b121bc0b07181c67f3dccbd8b86373e01479e60b20db6da696b676d5b63b2455e0c0f6e2d7c5445a25
+DIST nattka-0.1.2.tar.gz 73791 BLAKE2B 9e4d59f72b2e657958f7a8ac4b7d059079ab1c3ef6aea6544d4988aaa4acb3e09d6cb3a7cfcd7a01a4e7d891d7f2e544e3739470b0dbb961702e4c02575915b4 SHA512 1ef5af9b4c14dad5dce3eca427e77ec1f9f13137698a4cdb53dca58b1ff9f66d79508f69091ee96829a8d2703ebe7189a57e8257e20e586b90f2bf46a999cd0f
 DIST nattka-0.1.tar.gz 72870 BLAKE2B 0d4750a0367b3c00ee0de3eb37a7b15bbdc84ba693c2e3cb3a7baa1684c062f58458ded01b63afffe128b8d003cb14460bd60da91e61b100913801a3bf0d42ff SHA512 536be042d384f99631587108e2dfb24a3effbec1cf547b7f546fd8cbe736fa2e76ff1e9ca751ac7633fa34bea887da3ebe5967e915434ec8d8f6bd9c49a5a21f
diff --git a/app-portage/nattka/nattka-0.1.2.ebuild b/app-portage/nattka/nattka-0.1.2.ebuild
new file mode 100644 (file)
index 0000000..e8440d1
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+SRC_URI="https://github.com/mgorny/nattka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-util/pkgcheck[${PYTHON_USEDEP}]
+       dev-vcs/git
+       sys-apps/pkgcore[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+pkg_postinst() {
+       elog "NATTkA can optionally use:"
+       elog "  dev-python/networkx"
+       elog "to sort 'apply' output in dependency order."
+}