dev-python/pytest-shutil: Block py2 pytest-virtualenv
authorMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 19:47:54 +0000 (21:47 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 20:03:34 +0000 (22:03 +0200)
Since dev-python/pytest normally loads all plugins, and PMs don't
necessarily enforce dependencies of these that are not part of @world,
it is possible to break their depgraph and break pytest on py2.7
completely.  Add a blocker to make that harder.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild

index cb3daddd52780e35b39d6b860beb45315616699e..94e51a609069d985c2fa3454c02ab9cbc46d67a6 100644 (file)
@@ -27,6 +27,10 @@ RDEPEND="
        dev-python/mock[${PYTHON_USEDEP}]
        dev-python/termcolor[${PYTHON_USEDEP}]
 "
+# block pytest plugins that will be broken by the upgrade
+RDEPEND+="
+       !<dev-python/pytest-virtualenv-1.7.0-r1[python_targets_python2_7(-)]
+"
 
 BDEPEND="
        ${RDEPEND}