Update to 1.6.0 final.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 19 Oct 2006 16:17:54 +0000 (16:17 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 19 Oct 2006 16:17:54 +0000 (16:17 +0000)
Package-Manager: portage-2.1.2_pre3-r5

app-office/kexi/ChangeLog
app-office/kexi/files/digest-kexi-1.6.0 [new file with mode: 0644]
app-office/kexi/kexi-1.6.0.ebuild [new file with mode: 0644]

index 6934285cd677e4af32367d9a1160c0be4b7932a4..00806dfd2a9269f14f6ea3c1314faa83b48f06e4 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for app-office/kexi
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.53 2006/10/19 16:16:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/ChangeLog,v 1.54 2006/10/19 16:17:54 flameeyes Exp $
+
+  19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
+  Update to 1.6.0 final.
 
 *kexi-1.6.0 (19 Oct 2006)
 
diff --git a/app-office/kexi/files/digest-kexi-1.6.0 b/app-office/kexi/files/digest-kexi-1.6.0
new file mode 100644 (file)
index 0000000..2e01d4c
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 e669cf19b2e1c7db7029c0772c527c0d koffice-1.6.0.tar.bz2 56718478
+RMD160 be09c18005eb33f6dc35ab0359cc97a8a658ce7c koffice-1.6.0.tar.bz2 56718478
+SHA256 9eddaae640ada9bd184f001e2489854daf7094b73e5f15b0b8deffb4cc654ae2 koffice-1.6.0.tar.bz2 56718478
diff --git a/app-office/kexi/kexi-1.6.0.ebuild b/app-office/kexi/kexi-1.6.0.ebuild
new file mode 100644 (file)
index 0000000..3f4bb02
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.6.0.ebuild,v 1.1 2006/10/19 16:16:52 flameeyes Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated environment for database management."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+       sys-libs/readline
+       mysql? ( dev-db/mysql )
+       postgres? ( dev-libs/libpqxx )"
+
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig"
+
+KMCOPYLIB="
+       libkformula lib/kformula
+       libkofficecore lib/kofficecore
+       libkofficeui lib/kofficeui
+       libkopainter lib/kopainter
+       libkoproperty lib/koproperty
+       libkotext lib/kotext
+       libkwmf lib/kwmf
+       libkowmf lib/kwmf
+       libkstore lib/store
+       libkrossmain lib/kross/main/
+       libkrossapi lib/kross/api/"
+
+KMEXTRACTONLY="lib/"
+
+need-kde 3.4
+
+src_compile() {
+       local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"
+
+       kde-meta_src_compile
+}