app-office/moneyguru: Drop 2.13.1-r2
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 24 Feb 2020 13:33:42 +0000 (14:33 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 24 Feb 2020 13:36:26 +0000 (14:36 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-office/moneyguru/Manifest
app-office/moneyguru/moneyguru-2.13.1-r2.ebuild [deleted file]

index 7963e8611b873b271ec14f7a2d5f4a7cdb03753c..7263b73b216ee113f67660415db8421179c6cc70 100644 (file)
@@ -1,2 +1 @@
-DIST moneyguru-2.13.1.tar.gz 1665892 BLAKE2B 969286130c5336f4c41ccf0ee3cbfe55a13560f753e137ff5370184c5aff3e038995c79ad48620a5653552406ea6fb56d356a209cd36774751db4f8e3777354c SHA512 9544a2fe17d0c1d4a6f1ee6c52c79e66ca76da6a6ac35067f1961fe2b44a8efe20173ee5932a91adeeebcb0a522b544df11ad388cb4c453a0641060d75f2a17c
 DIST moneyguru-3.0.1.tar.gz 1052191 BLAKE2B 30ea5eaa7b6256a33e98dc590015f563a3d5f6a10ccf26911e397dced79dfffa3b55941900ecf2cf3915ad0055db0c4c95b2f10c0c55e34d972afe32d714a588 SHA512 fe0de1d01340d124f8f385a4713c6748d2d445c653b508ad08303a3fea5192a0d88be9feb4984d19d4608436eb47de830d1c3dc6680d23aeff81107d27dcaf10
diff --git a/app-office/moneyguru/moneyguru-2.13.1-r2.ebuild b/app-office/moneyguru/moneyguru-2.13.1-r2.ebuild
deleted file mode 100644 (file)
index 31987d2..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit python-single-r1
-
-DESCRIPTION="Future-aware personal finances management"
-HOMEPAGE="https://hardcoded.net/moneyguru"
-SRC_URI="https://download.hardcoded.net/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="${PYTHON_DEPS}
-       dev-db/sqlite:3
-       dev-libs/glib:2
-       $(python_gen_cond_dep '
-               dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,widgets,printsupport]
-       ')
-       dev-qt/qttranslations"
-DEPEND="${RDEPEND}
-       test? (
-               $(python_gen_cond_dep '
-                       <dev-python/pytest-4[${PYTHON_MULTI_USEDEP}]
-               ')
-               dev-util/cunit
-       )"
-
-_emake() {
-       emake CFLAGS="\$(DEFAULT_CFLAGS) ${CFLAGS}" \
-               SHEBANG="${PYTHON}" \
-               DESTDIR="${ED}" \
-               PREFIX=/usr \
-               $@
-}
-
-src_compile() {
-       _emake
-}
-
-src_install() {
-       _emake install
-}
-
-src_test() {
-       emake -C ccore CFLAGS="\$(DEFAULT_CFLAGS) ${CFLAGS}" tests
-       pytest -vv core || die "Tests failed with ${EPYTHON}"
-}