net-misc/wget: Revbumps to avoid automagic dep on net-libs/libpsl
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 11:18:45 +0000 (13:18 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 12 Jun 2019 11:21:24 +0000 (13:21 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-misc/wget/metadata.xml
net-misc/wget/wget-1.20.3-r1.ebuild [moved from net-misc/wget/wget-1.20.3.ebuild with 99% similarity]
net-misc/wget/wget-1.20.3-r2.ebuild [new file with mode: 0644]

index 85b6f1cfa8ce7d11a8b39a9ceed394f8e15e06c5..d0383b4091d212b7ec8b6339f911ef9c9fd301d3 100644 (file)
@@ -6,6 +6,7 @@
  <name>Gentoo Base System</name>
  </maintainer>
 <use>
+ <flag name="cookie_check">Enable cookie checks via <pkg>net-libs/libpsl</pkg></flag>
  <flag name="ntlm">Enable support for NTLM (Windows-based) authorization</flag>
  <flag name="uuid">Generate UUIDs for the WARC (Web ARChive file format) using libuuid; otherwise use a simple RNG (random number generator)</flag>
 </use>
similarity index 99%
rename from net-misc/wget/wget-1.20.3.ebuild
rename to net-misc/wget/wget-1.20.3-r1.ebuild
index 624c485f43ec8610c51e72a902c3eb4beeabdc8a..d71dbd3cf2a94bf1e6b63890c8d8c642488043bd 100644 (file)
@@ -88,6 +88,7 @@ src_configure() {
                --disable-pcre
                --disable-rpath
                --without-included-libunistring
+               --without-libpsl
                --without-libunistring-prefix
                $(use_enable debug)
                $(use_enable idn iri)
diff --git a/net-misc/wget/wget-1.20.3-r2.ebuild b/net-misc/wget/wget-1.20.3-r2.ebuild
new file mode 100644 (file)
index 0000000..59a3d90
--- /dev/null
@@ -0,0 +1,122 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit flag-o-matic python-any-r1 toolchain-funcs
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="https://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="cookie_check debug gnutls idn ipv6 libressl nls ntlm pcre +ssl static test uuid zlib"
+REQUIRED_USE=" ntlm? ( !gnutls ssl ) gnutls? ( ssl )"
+
+# Force a newer libidn2 to avoid libunistring deps. #612498
+LIB_DEPEND="
+       cookie_check? ( net-libs/libpsl )
+       idn? ( >=net-dns/libidn2-0.14:=[static-libs(+)] )
+       pcre? ( dev-libs/libpcre2[static-libs(+)] )
+       ssl? (
+               gnutls? ( net-libs/gnutls:0=[static-libs(+)] )
+               !gnutls? (
+                       !libressl? ( dev-libs/openssl:0=[static-libs(+)] )
+                       libressl? ( dev-libs/libressl:0=[static-libs(+)] )
+               )
+       )
+       uuid? ( sys-apps/util-linux[static-libs(+)] )
+       zlib? ( sys-libs/zlib[static-libs(+)] )
+"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="
+       ${RDEPEND}
+       static? ( ${LIB_DEPEND} )
+       test? (
+               ${PYTHON_DEPS}
+               dev-lang/perl
+               dev-perl/HTTP-Daemon
+               dev-perl/HTTP-Message
+               dev-perl/IO-Socket-SSL
+       )
+"
+BDEPEND="
+       app-arch/xz-utils
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )
+"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
+
+pkg_setup() {
+       use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # revert some hack that breaks linking, bug #585924
+       if [[ ${CHOST} == *-darwin* ]] \
+       || [[ ${CHOST} == *-solaris* ]] \
+       || [[ ${CHOST} == *-uclibc* ]] \
+       || [[ ${CHOST} == *-cygwin* ]] \
+       ; then
+               sed -i \
+                       -e 's/^  LIBICONV=$/:/' \
+                       configure || die
+       fi
+}
+
+src_configure() {
+       # fix compilation on Solaris, we need filio.h for FIONBIO as used in
+       # the included gnutls -- force ioctl.h to include this header
+       [[ ${CHOST} == *-solaris* ]] && append-cppflags -DBSD_COMP=1
+
+       if use static ; then
+               append-ldflags -static
+               tc-export PKG_CONFIG
+               PKG_CONFIG+=" --static"
+       fi
+
+       # There is no flag that controls this.  libunistring-prefix only
+       # controls the search path (which is why we turn it off below).
+       # Further, libunistring is only needed w/older libidn2 installs,
+       # and since we force the latest, we can force off libunistring. #612498
+       local myeconfargs=(
+               --disable-assert
+               --disable-pcre
+               --disable-rpath
+               --without-included-libunistring
+               --without-libunistring-prefix
+               $(use_enable debug)
+               $(use_enable idn iri)
+               $(use_enable ipv6)
+               $(use_enable nls)
+               $(use_enable ntlm)
+               $(use_enable pcre pcre2)
+               $(use_enable ssl digest)
+               $(use_enable ssl opie)
+               $(use_with cookie_check libpsl)
+               $(use_with idn libidn)
+               $(use_with ssl ssl $(usex gnutls gnutls openssl))
+               $(use_with uuid libuuid)
+               $(use_with zlib)
+       )
+       ac_cv_libunistring=no \
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       sed -i \
+               -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
+               "${ED}"/etc/wgetrc \
+               "${ED}"/usr/share/man/man1/wget.1 \
+               "${ED}"/usr/share/info/wget.info \
+               || die
+}