x11-apps/igt-gpu-tools: Version bump to 1.24
authorMatt Turner <mattst88@gentoo.org>
Sat, 13 Jul 2019 17:43:02 +0000 (10:43 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 13 Jul 2019 17:43:06 +0000 (10:43 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-apps/igt-gpu-tools/Manifest
x11-apps/igt-gpu-tools/igt-gpu-tools-1.24.ebuild [new file with mode: 0644]

index f9704cb902767f524e58517b745efa691d8de416..159cb663eae9b9e7c0134e78f27c67ed37986011 100644 (file)
@@ -1 +1,2 @@
 DIST igt-gpu-tools-1.23.tar.xz 1045716 BLAKE2B f5e55ce9b682f2a9f2c6ab73c1e8e933ebea09b343f3af02df50b5bdce3e2ac313b1f92709c6de0d9fc7ffe2e2c9dfa95d2918ae9bd561cc285cff30fe59c6fd SHA512 8697265a978359e28983f483bf95819844597fc2080923d15d0587f6d648081af27e8ea318873e20103bbf8446b9f1005c6bc90a6276d3169837abd181f96839
+DIST igt-gpu-tools-1.24.tar.xz 1207436 BLAKE2B 0b04033be0195a4fee5611aeae2f47334ce1de5df65c652ebc0b36d1185286268bb426f472e3c1311ff576e8184e7a4efb95ef3181006ed8c448ea76452940d7 SHA512 22c25e27ead64f561fe8f46b132d6c7562a90d7bff09dc2618a532b16d7b8fdf54ed94d986a45655657b54219d350ce1b1e6c89da2b6073024e9bbe0973fa190
diff --git a/x11-apps/igt-gpu-tools/igt-gpu-tools-1.24.ebuild b/x11-apps/igt-gpu-tools/igt-gpu-tools-1.24.ebuild
new file mode 100644 (file)
index 0000000..8662c01
--- /dev/null
@@ -0,0 +1,103 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGIT_REPO_URI="https://gitlab.freedesktop.org/drm/${PN}.git"
+if [[ ${PV} = *9999* ]]; then
+       GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Intel GPU userland tools"
+
+HOMEPAGE="https://01.org/linuxgraphics https://gitlab.freedesktop.org/drm/igt-gpu-tools"
+if [[ ${PV} = *9999* ]]; then
+       SRC_URI=""
+else
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://www.x.org/releases/individual/app/${P}.tar.xz"
+fi
+LICENSE="MIT"
+SLOT="0"
+IUSE="chamelium doc man overlay runner unwind valgrind video_cards_amdgpu video_cards_intel video_cards_nouveau X xv"
+REQUIRED_USE="
+       || ( video_cards_amdgpu video_cards_intel video_cards_nouveau )
+       overlay? (
+               video_cards_intel
+               || ( X xv )
+       )
+"
+RESTRICT="test"
+
+RDEPEND="
+       dev-libs/elfutils
+       dev-libs/glib:2
+       sys-apps/kmod:=
+       sys-libs/libunwind:=
+       sys-libs/zlib:=
+       sys-process/procps:=
+       virtual/libudev:=
+       >=x11-libs/cairo-1.12.0[X?]
+       >=x11-libs/libdrm-2.4.82[video_cards_amdgpu?,video_cards_intel?,video_cards_nouveau?]
+       >=x11-libs/libpciaccess-0.10
+       x11-libs/pixman
+       chamelium? (
+               dev-libs/xmlrpc-c[curl]
+               sci-libs/gsl
+               media-libs/alsa-lib:=
+       )
+       overlay? (
+               >=x11-libs/libXrandr-1.3
+               xv? (
+                       x11-libs/libX11
+                       x11-libs/libXext
+                       x11-libs/libXv
+               )
+       )
+       runner? ( dev-libs/json-c:= )
+       unwind? ( sys-libs/libunwind )
+       valgrind? ( dev-util/valgrind )
+       "
+DEPEND="${RDEPEND}
+       doc? ( >=dev-util/gtk-doc-1.25-r1 )
+       man? ( dev-python/docutils )
+       overlay? (
+               >=dev-util/peg-0.1.18
+               x11-base/xorg-proto
+       )
+       video_cards_intel? (
+               sys-devel/bison
+               sys-devel/flex
+       )
+"
+
+src_prepare() {
+       sed -e "s/find_program('rst2man-3'/find_program('rst2man.py', 'rst2man-3'/" -i man/meson.build
+       default_src_prepare
+}
+
+src_configure() {
+       local gpus=""
+       use video_cards_amdgpu  && gpus+="amdgpu,"
+       use video_cards_intel   && gpus+="intel,"
+       use video_cards_nouveau && gpus+="nouveau,"
+
+       local overlay_backends=""
+       use overlay && use xv && overlay_backends+="xv,"
+       use overlay && use X && overlay_backends+="x,"
+
+       local emesonargs=(
+               $(meson_feature chamelium build_chamelium)
+               $(meson_feature doc build_docs)
+               $(meson_feature man build_man)
+               $(meson_feature overlay build_overlay)
+               $(meson_feature runner build_runner)
+               $(meson_feature doc build_tests) # Test build is required for docs
+               $(meson_feature valgrind with_valgrind)
+               $(meson_feature unwind with_libunwind)
+               -Doverlay_backends=${overlay_backends%?}
+               -Dwith_libdrm=${gpus%?}
+       )
+       meson_src_configure
+}