dev-python/sphinx-testing: Add a py3-only revision
authorMichał Górny <mgorny@gentoo.org>
Mon, 9 Dec 2019 07:46:03 +0000 (08:46 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 9 Dec 2019 08:39:36 +0000 (09:39 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..63d200f
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+       dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+       )"
+
+python_test() {
+       # NB: while tests don't stricly use nose, they rely on some side
+       # effects of using it
+       nosetests -v || die "Tests fail with ${EPYTHON}"
+}