gnome-extra/cinnamon-screensaver: 4.4.1 version bump
authorMatthew Turnbull <sparky@bluefang-logic.com>
Wed, 13 May 2020 02:21:46 +0000 (22:21 -0400)
committerMatt Turner <mattst88@gentoo.org>
Fri, 29 May 2020 00:10:45 +0000 (17:10 -0700)
Update cinnamon-screensaver to 4.4.1. Python 3.7/3.8
support and fix shebangs. Cleanup dependencies.
Upstream dropped webkit and xscreensaver support.

Bug: https://bugs.gentoo.org/718316
Bug: https://bugs.gentoo.org/704532
Closes: https://bugs.gentoo.org/560764
Closes: https://bugs.gentoo.org/613736
Closes: https://bugs.gentoo.org/720152
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew S. Turnbull <sparky@bluefang-logic.com>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
gnome-extra/cinnamon-screensaver/Manifest
gnome-extra/cinnamon-screensaver/cinnamon-screensaver-4.4.1.ebuild [new file with mode: 0644]
gnome-extra/cinnamon-screensaver/metadata.xml

index 9cda7dfe33fe665696a05164180556b352e791d3..5b05aa84e614b79c8b7863e9f532b1f00a64deb0 100644 (file)
@@ -1 +1,2 @@
 DIST cinnamon-screensaver-4.0.1.tar.gz 156640 BLAKE2B e82354ce36fc325f524e60680c51d46ba7924154e2ff64514687498a7ebbf13d626e5441177d0679c763a4bd3c10a2b7e08ed01470358bc4606be90d37867570 SHA512 c1262d6c1e9575da8007f41f637ab9f7ba33ad5a3a909a7b756cef1f4cb0f323ea4d89fd7498d9589975b9fa6e4715d631413eec7fbcb9c3b46d3a42e02ac7bf
+DIST cinnamon-screensaver-4.4.1.tar.gz 160214 BLAKE2B df19a370c76648e0717565a3aab4785c3d8b48b20b9d87cc5426506f196db72872642d0ed1109a40986311c0ad7a5c17fbdcfc69681083afd3884c04822c6afa SHA512 92050febcfd41ad03b277cef60b95080d56b8fd985d064e9420a3357d7d0475355a4ca55965e581ae45410df8f19f3c031f6df0e3eec5b6b78aee7141d0244f7
diff --git a/gnome-extra/cinnamon-screensaver/cinnamon-screensaver-4.4.1.ebuild b/gnome-extra/cinnamon-screensaver/cinnamon-screensaver-4.4.1.ebuild
new file mode 100644 (file)
index 0000000..d5eb0b7
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools gnome2 python-single-r1
+
+DESCRIPTION="Screensaver for Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/"
+SRC_URI="https://github.com/linuxmint/cinnamon-screensaver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug systemd xinerama"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+       >=dev-libs/glib-2.37.3:2[dbus]
+       >=x11-libs/gtk+-3.1.4:3[introspection]
+       >=gnome-extra/cinnamon-desktop-4.4:0=
+       >=gnome-base/gsettings-desktop-schemas-0.1.7
+       >=dev-libs/dbus-glib-0.78
+
+       sys-apps/dbus
+       sys-libs/pam
+       x11-libs/libX11
+       x11-libs/libXext
+       x11-libs/libXrandr
+       x11-themes/adwaita-icon-theme
+
+       ${PYTHON_DEPS}
+
+       xinerama? ( x11-libs/libXinerama )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       $(python_gen_cond_dep '
+               dev-python/pygobject:3[${PYTHON_USEDEP}]
+               dev-python/setproctitle[${PYTHON_USEDEP}]
+               dev-python/xapp[${PYTHON_USEDEP}]
+               dev-python/psutil[${PYTHON_USEDEP}]
+       ')
+       systemd? ( >=sys-apps/systemd-31 )
+       !systemd? ( sys-auth/elogind )
+"
+DEPEND="${COMMON_DEPEND}
+       dev-util/gdbus-codegen
+       >=dev-util/intltool-0.40
+       sys-devel/gettext
+       virtual/pkgconfig
+       x11-base/xorg-proto
+"
+
+src_prepare() {
+       python_fix_shebang src
+
+       eautoreconf
+       gnome2_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               $(usex debug --enable-debug ' ') \
+               $(use_enable xinerama)
+}
index 00e290bb5707c161ecd09d8e3d5bb1e88b1bf76c..7b8be711a69965dcabef516c7c28ead2d7032d5b 100644 (file)
@@ -5,6 +5,14 @@
                <email>cinnamon@gentoo.org</email>
                <name>Cinnamon Project</name>
        </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <maintainer type="person">
+               <email>sparky@bluefang-logic.com</email>
+               <name>Matthew Turnbull</name>
+       </maintainer>
        <upstream>
                <remote-id type="github">linuxmint/cinnamon-screensaver</remote-id>
        </upstream>