Version bumped to 0.148 and removed some older and unused ebuilds. Closing bug ...
authorChris Gianelloni <wolf31o2@gentoo.org>
Tue, 6 Jun 2006 14:57:52 +0000 (14:57 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Tue, 6 Jun 2006 14:57:52 +0000 (14:57 +0000)
Package-Manager: portage-2.1_rc3-r2

net-misc/tsclient/ChangeLog
net-misc/tsclient/files/digest-tsclient-0.140
net-misc/tsclient/files/digest-tsclient-0.148 [new file with mode: 0644]
net-misc/tsclient/tsclient-0.148.ebuild [new file with mode: 0644]

index bb19ce53b2c760c71b52f29aec96ab4eeca53ae8..9f0fedb5c4c62364e806a7b21ab830473b31b2e7 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for net-misc/tsclient
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tsclient/ChangeLog,v 1.19 2006/01/14 18:59:50 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tsclient/ChangeLog,v 1.20 2006/06/06 14:57:52 wolf31o2 Exp $
+
+*tsclient-0.148 (06 Jun 2006)
+
+  06 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  -files/tsclient.desktop, -tsclient-0.116.ebuild, -tsclient-0.120.ebuild,
+  -tsclient-0.124.ebuild, +tsclient-0.148.ebuild:
+  Version bumped to 0.148 and removed some older and unused ebuilds. Closing
+  bug #135031.
 
   14 Jan 2006; Saleem Abdulrasool <compnerd@gentoo.org>
   +files/tsclient-0.140-connect-path-builder.patch, tsclient-0.140.ebuild:
index a7b4cd28adc976bc06d34fae99b2cabedc7fb542..5c929b3df9457c12d6c775e79052551b3b44363c 100644 (file)
@@ -1 +1,3 @@
 MD5 c10a5a151a1ece653f62e07b11228534 tsclient-0.140.tar.gz 404231
+RMD160 5dffd3b3c30dc53c733a7504ace62c23e5f0a1cd tsclient-0.140.tar.gz 404231
+SHA256 4a94b68885e101dda429493caff18b5254c1240aafdb98a74ea0d775dd83b713 tsclient-0.140.tar.gz 404231
diff --git a/net-misc/tsclient/files/digest-tsclient-0.148 b/net-misc/tsclient/files/digest-tsclient-0.148
new file mode 100644 (file)
index 0000000..929cc58
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 06a6ff59b7c8ca26d4ea37340ed77423 tsclient-0.148.tar.gz 490745
+RMD160 8cead17e593e5f4ef23b85ffd5c339f98453517b tsclient-0.148.tar.gz 490745
+SHA256 8d045530a5f1dd38e809162047a5806ad38c2e2d5d685d5b90b965780b4ffca6 tsclient-0.148.tar.gz 490745
diff --git a/net-misc/tsclient/tsclient-0.148.ebuild b/net-misc/tsclient/tsclient-0.148.ebuild
new file mode 100644 (file)
index 0000000..076cd4d
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tsclient/tsclient-0.148.ebuild,v 1.1 2006/06/06 14:57:52 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="GTK2 frontend for rdesktop"
+HOMEPAGE="http://www.gnomepro.com/tsclient"
+SRC_URI="http://www.gnomepro.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="debug vnc"
+
+RDEPEND=">=x11-libs/gtk+-2.0
+       >=dev-libs/glib-2.0
+       >=net-misc/rdesktop-1.3.0
+       >=gnome-base/libgnomeui-2.0
+       >=gnome-base/gnome-panel-2.0
+       vnc? (
+               || (
+                       net-misc/vnc
+                       net-misc/tightvnc ) )"
+
+DEPEND="${RDEPEND}
+       >=dev-util/intltool-0.27
+       dev-util/pkgconfig"
+
+src_compile() {
+       econf $(use_enable debug) || die "configure failed"
+       emake || die "make failed"
+}
+
+src_install() {
+       make DESTDIR=${D} install || die "install failed"
+       dodoc AUTHORS NEWS README VERSION
+}
+
+pkg_postinst() {
+       if use vnc
+       then
+               ewarn "VNC support is still experimental.  Be sure to read"
+               ewarn "/usr/share/doc/${PF}/README.gz for more infomration."
+               echo
+       fi
+}