dev-libs/libinput: Move tools needed for USE="doc" to BDEPEND.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Mon, 13 May 2019 03:11:06 +0000 (05:11 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 13 May 2019 08:06:41 +0000 (10:06 +0200)
Fix commented out dependencies for USE="test".

Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Closes: https://bugs.gentoo.org/685774
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-libs/libinput/libinput-1.12.6.ebuild
dev-libs/libinput/libinput-1.13.1.ebuild
dev-libs/libinput/libinput-1.13.2.ebuild

index fd10ed0a4e7d9ed66d6ef005a22ffc55e11e7901..213dd9f0cc1aa89d917653711315233af0c52470 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2014-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -18,14 +18,8 @@ IUSE="doc input_devices_wacom"
 # Other tests are just about logs, exported symbols and autotest of the test library.
 RESTRICT="test"
 
-RDEPEND="
-       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
-       >=dev-libs/libevdev-1.3
-       >=sys-libs/mtdev-1.1
-       virtual/libudev:=
-       virtual/udev
-"
-DEPEND="${RDEPEND}
+BDEPEND="
+       virtual/pkgconfig
        doc? (
                $(python_gen_any_dep '
                        dev-python/commonmark[${PYTHON_USEDEP}]
@@ -37,13 +31,16 @@ DEPEND="${RDEPEND}
                >=media-gfx/graphviz-2.38.0
        )
 "
-#      test? (
-#              >=dev-libs/check-0.9.10
-#              dev-util/valgrind
-#              sys-libs/libunwind )
-BDEPEND="
-       virtual/pkgconfig
+#      test? ( dev-util/valgrind )
+RDEPEND="
+       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+       >=dev-libs/libevdev-1.3
+       >=sys-libs/mtdev-1.1
+       virtual/libudev:=
+       virtual/udev
 "
+DEPEND="${RDEPEND}"
+#      test? ( >=dev-libs/check-0.9.10 )
 
 python_check_deps() {
        has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
index f8e313004d15442047c329b5d9f7d4342dac7803..bc7c6286e4918a96b35ef50f0c59a96edabec36f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2014-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -18,14 +18,8 @@ IUSE="doc input_devices_wacom"
 # Other tests are just about logs, exported symbols and autotest of the test library.
 RESTRICT="test"
 
-RDEPEND="
-       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
-       >=dev-libs/libevdev-1.3
-       >=sys-libs/mtdev-1.1
-       virtual/libudev:=
-       virtual/udev
-"
-DEPEND="${RDEPEND}
+BDEPEND="
+       virtual/pkgconfig
        doc? (
                $(python_gen_any_dep '
                        dev-python/commonmark[${PYTHON_USEDEP}]
@@ -37,13 +31,16 @@ DEPEND="${RDEPEND}
                >=media-gfx/graphviz-2.38.0
        )
 "
-#      test? (
-#              >=dev-libs/check-0.9.10
-#              dev-util/valgrind
-#              sys-libs/libunwind )
-BDEPEND="
-       virtual/pkgconfig
+#      test? ( dev-util/valgrind )
+RDEPEND="
+       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+       >=dev-libs/libevdev-1.3
+       >=sys-libs/mtdev-1.1
+       virtual/libudev:=
+       virtual/udev
 "
+DEPEND="${RDEPEND}"
+#      test? ( >=dev-libs/check-0.9.10 )
 
 python_check_deps() {
        has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
index f8e313004d15442047c329b5d9f7d4342dac7803..bc7c6286e4918a96b35ef50f0c59a96edabec36f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2014-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -18,14 +18,8 @@ IUSE="doc input_devices_wacom"
 # Other tests are just about logs, exported symbols and autotest of the test library.
 RESTRICT="test"
 
-RDEPEND="
-       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
-       >=dev-libs/libevdev-1.3
-       >=sys-libs/mtdev-1.1
-       virtual/libudev:=
-       virtual/udev
-"
-DEPEND="${RDEPEND}
+BDEPEND="
+       virtual/pkgconfig
        doc? (
                $(python_gen_any_dep '
                        dev-python/commonmark[${PYTHON_USEDEP}]
@@ -37,13 +31,16 @@ DEPEND="${RDEPEND}
                >=media-gfx/graphviz-2.38.0
        )
 "
-#      test? (
-#              >=dev-libs/check-0.9.10
-#              dev-util/valgrind
-#              sys-libs/libunwind )
-BDEPEND="
-       virtual/pkgconfig
+#      test? ( dev-util/valgrind )
+RDEPEND="
+       input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+       >=dev-libs/libevdev-1.3
+       >=sys-libs/mtdev-1.1
+       virtual/libudev:=
+       virtual/udev
 "
+DEPEND="${RDEPEND}"
+#      test? ( >=dev-libs/check-0.9.10 )
 
 python_check_deps() {
        has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \