sys-apps/policycoreutils: bump to 3.0_rc2
authorJason Zaman <perfinion@gentoo.org>
Fri, 29 Nov 2019 10:28:31 +0000 (18:28 +0800)
committerJason Zaman <perfinion@gentoo.org>
Mon, 2 Dec 2019 14:49:16 +0000 (22:49 +0800)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
sys-apps/policycoreutils/Manifest
sys-apps/policycoreutils/policycoreutils-3.0_rc2.ebuild [new file with mode: 0644]

index 13349b63e5938d43d225801a4f166fbde95ab83d..e60a04e7e962b2524d431c21060b50770d73fcb7 100644 (file)
@@ -1,3 +1,4 @@
 DIST policycoreutils-2.8.tar.gz 2796775 BLAKE2B 36115cc2faf72a4b647312f8faaf4762d7f2fb56bf0531ccadeb46b100c9e577f3148fe6890925d3fed94ac22803dc61729781e54bd0ddeb1539ccce2ec2a29b SHA512 2b4a70836fd8727a16b8f8d4afcc39c9461ab6f5bc1ba5ce5833d41150da921ebb3c9bdbd1cfa7dd31fd382ba18b5433ca9b63bce58bd290db81fa9bedfe29f3
 DIST policycoreutils-2.9.tar.gz 2819360 BLAKE2B b0af912e3b4fb2c9598b10ce413c8ffb3f5972a4d5d59270cff40abe8d4e385e0664e24a4f533a95ad2d1657644f3368213f955ac63d9f8c46a661417b07c8b3 SHA512 d8356115671ba66de05f1c13193ab47fab69cc4d09603a92171ed40afafc084dd191591bf336b7d722de637378ad09622ebb6eca85c06063ca9ddd6db10e02a2
+DIST policycoreutils-3.0-rc2.tar.gz 2818551 BLAKE2B 2d589bf66eeee627612ca491c3c9399f815d307e39d5f48c269cc41427718f55dc686e4da0c4e2e806538c06cb9683e09d1de707341b495bf4d943b4baec0e2f SHA512 a2affe9da05a3970db5220879ec6a9ea2c9d8075b4411ba93430fdae93d8414fdab4367e008adc9839c24cb9c3ad2cfcf37aee83dcd2a4da11d030b0bdfae49d
 DIST policycoreutils-extra-1.36.tar.bz2 8830 BLAKE2B 6d98e41ea379d3e95221a6e53d8a8b144e4e15ca5581381e76a529dbbaca304d5587b30419797c8c70cbd7c2b2588e5ecd62adcf97294e429950899c1c318346 SHA512 c6a18e6fb2d65f51dc55b88907f23241f2fbfc033d3d2888b109596d9ed31d509b2c93456727ea4d1f98544831afb15c449ff72d6aedf93b9e474b27817f7fb3
diff --git a/sys-apps/policycoreutils/policycoreutils-3.0_rc2.ebuild b/sys-apps/policycoreutils/policycoreutils-3.0_rc2.ebuild
new file mode 100644 (file)
index 0000000..c59a9c0
--- /dev/null
@@ -0,0 +1,176 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+PYTHON_REQ_USE="xml"
+
+inherit multilib python-r1 toolchain-funcs bash-completion-r1
+
+MY_P="${P//_/-}"
+
+MY_RELEASEDATE="20191122"
+EXTRAS_VER="1.36"
+SEMNG_VER="${PV}"
+SELNX_VER="${PV}"
+SEPOL_VER="${PV}"
+
+IUSE="audit pam dbus"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+       SRC_URI="https://dev.gentoo.org/~perfinion/distfiles/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
+       S1="${WORKDIR}/${MY_P}/${PN}"
+       S2="${WORKDIR}/policycoreutils-extra"
+       S="${S1}"
+else
+       SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz
+               https://dev.gentoo.org/~perfinion/distfiles/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
+       KEYWORDS="~amd64 ~arm64 ~mips ~x86"
+       S1="${WORKDIR}/${MY_P}"
+       S2="${WORKDIR}/policycoreutils-extra"
+       S="${S1}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python,${PYTHON_USEDEP}]
+       >=sys-libs/libcap-1.10-r10:=
+       >=sys-libs/libsemanage-${SEMNG_VER}:=[python,${PYTHON_USEDEP}]
+       sys-libs/libcap-ng:=
+       >=sys-libs/libsepol-${SEPOL_VER}:=
+       >=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
+       sys-devel/gettext
+       dev-python/ipy[${PYTHON_USEDEP}]
+       dbus? (
+               sys-apps/dbus
+               dev-libs/dbus-glib:=
+       )
+       audit? ( >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}] )
+       pam? ( sys-libs/pam:= )
+       ${PYTHON_DEPS}"
+
+### libcgroup -> seunshare
+### dbus -> restorecond
+
+# pax-utils for scanelf used by rlpkg
+RDEPEND="${DEPEND}
+       app-misc/pax-utils
+       !<sys-apps/openrc-0.14"
+
+PDEPEND="sys-apps/semodule-utils
+       sys-apps/selinux-python"
+
+src_unpack() {
+       # Override default one because we need the SRC_URI ones even in case of 9999 ebuilds
+       default
+       if [[ ${PV} == 9999 ]] ; then
+               git-r3_src_unpack
+       fi
+}
+
+src_prepare() {
+       S="${S1}"
+       cd "${S}" || die "Failed to switch to ${S}"
+       if [[ ${PV} != 9999 ]] ; then
+               # If needed for live ebuilds please use /etc/portage/patches
+               eapply "${FILESDIR}/policycoreutils-2.7-0001-newrole-not-suid.patch"
+       fi
+
+       # rlpkg is more useful than fixfiles
+       sed -i -e '/^all/s/fixfiles//' "${S}/scripts/Makefile" \
+               || die "fixfiles sed 1 failed"
+       sed -i -e '/fixfiles/d' "${S}/scripts/Makefile" \
+               || die "fixfiles sed 2 failed"
+
+       eapply_user
+
+       sed -i 's/-Werror//g' "${S1}"/*/Makefile || die "Failed to remove Werror"
+
+       python_copy_sources
+       # Our extra code is outside the regular directory, so set it to the extra
+       # directory. We really should optimize this as it is ugly, but the extra
+       # code is needed for Gentoo at the same time that policycoreutils is present
+       # (so we cannot use an additional package for now).
+       S="${S2}"
+       python_copy_sources
+}
+
+src_compile() {
+       building() {
+               emake -C "${BUILD_DIR}" \
+                       AUDIT_LOG_PRIVS="y" \
+                       AUDITH="$(usex audit y n)" \
+                       PAMH="$(usex pam y n)" \
+                       INOTIFYH="$(usex dbus y n)" \
+                       SESANDBOX="n" \
+                       CC="$(tc-getCC)" \
+                       LIBDIR="\$(PREFIX)/$(get_libdir)"
+       }
+       S="${S1}" # Regular policycoreutils
+       python_foreach_impl building
+       S="${S2}" # Extra set
+       python_foreach_impl building
+}
+
+src_install() {
+       # Python scripts are present in many places. There are no extension modules.
+       installation-policycoreutils() {
+               einfo "Installing policycoreutils"
+               emake -C "${BUILD_DIR}" DESTDIR="${D}" \
+                       AUDIT_LOG_PRIVS="y" \
+                       AUDITH="$(usex audit y n)" \
+                       PAMH="$(usex pam y n)" \
+                       INOTIFYH="$(usex dbus y n)" \
+                       SESANDBOX="n" \
+                       CC="$(tc-getCC)" \
+                       LIBDIR="\$(PREFIX)/$(get_libdir)" \
+                       install
+               python_optimize
+       }
+
+       installation-extras() {
+               einfo "Installing policycoreutils-extra"
+               emake -C "${BUILD_DIR}" \
+                       DESTDIR="${D}" \
+                       install
+               python_optimize
+       }
+
+       S="${S1}" # policycoreutils
+       python_foreach_impl installation-policycoreutils
+       S="${S2}" # extras
+       python_foreach_impl installation-extras
+       S="${S1}" # back for later
+
+       # remove redhat-style init script
+       rm -fR "${D}/etc/rc.d" || die
+
+       # compatibility symlinks
+       dosym /sbin/setfiles /usr/sbin/setfiles
+       bashcomp_alias setsebool getsebool
+
+       # location for policy definitions
+       dodir /var/lib/selinux
+       keepdir /var/lib/selinux
+
+       # Set version-specific scripts
+       for pyscript in rlpkg; do
+         python_replicate_script "${ED}/usr/sbin/${pyscript}"
+       done
+}
+
+pkg_postinst() {
+       for POLICY_TYPE in ${POLICY_TYPES} ; do
+               # There have been some changes to the policy store, rebuilding now.
+               # https://marc.info/?l=selinux&m=143757277819717&w=2
+               einfo "Rebuilding store ${POLICY_TYPE} (without re-loading)."
+               semodule -s "${POLICY_TYPE}" -n -B || die "Failed to rebuild policy store ${POLICY_TYPE}"
+       done
+}