dev-util/bcc: version bump to 0.7.0
authorZac Medico <zmedico@gentoo.org>
Wed, 21 Nov 2018 04:39:26 +0000 (20:39 -0800)
committerZac Medico <zmedico@gentoo.org>
Wed, 21 Nov 2018 05:04:54 +0000 (21:04 -0800)
Reported-by: Andy Dalton <andy.dalton@gmail.com>
Closes: https://bugs.gentoo.org/671604
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Zac Medico <zmedico@gentoo.org>
dev-util/bcc/Manifest
dev-util/bcc/bcc-0.7.0.ebuild [new file with mode: 0644]

index 0eba5f3d0ac42ce9427b41c2c505738c86be1ca5..d199a94a968d7d0d84a83768d36d788f794e3769 100644 (file)
@@ -1,2 +1,3 @@
 DIST bcc-0.5.0_p20171230.tar.gz 1773522 BLAKE2B bc5ec32570cf230f071c10d2925a8c8a777c60c22d31bbf72f3cad1718e59dacd604e45a326ff2a941aa519a2b3544bc7376dd40ceafe154c497b488e0ec1b9b SHA512 d8e810768b5801c0beef98a13ee23eb8aa756f7f8a3e35f6a391958e30affc5a8622a9b75c785f66d86761105045cb2b1c7ce284f3ac3b482a4605987bea9f30
 DIST bcc-0.6.0.tar.gz 1986593 BLAKE2B 514c2c781eb94d99560232d8050b5664ce3565622b236e78cd111be27b3482849965600a1d574f59243917672f00bb3cef65cab63103f6c4a5cf62024c683d9b SHA512 1a8edf6da22f3119a74cf43f03ec83b97ed2f6fc18828d750d8a695ac1451b6b3209e5d2cf48bc87f53fa9447e8813a018a58d31588d477e4aa364a2d0217e80
+DIST bcc-0.7.0.tar.gz 2009289 BLAKE2B 370b553521289d983d1165633e76a5e405250b9b09dbf3e78c127d232908e73facce06097ce4dbf0bbccda929b6715a9b7460affe123556087c8ca00b8d62c0b SHA512 ebe6c4cbecba2d587c69af71ddc8cb451b2b8e1d49ef887f291c813320c2c60d49357500fc2751d5b418df2be1d02763c385d89de6efa6e10f049c25acf01b4e
diff --git a/dev-util/bcc/bcc-0.7.0.ebuild b/dev-util/bcc/bcc-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..9d90ec4
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit cmake-utils linux-info python-single-r1 python-utils-r1
+
+DESCRIPTION="Tools for BPF-based Linux IO analysis, networking, monitoring, and more"
+HOMEPAGE="https://iovisor.github.io/bcc/"
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://github.com/iovisor/bcc/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RESTRICT="test"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=dev-libs/elfutils-0.166:=
+       sys-devel/clang:=
+       >=sys-devel/llvm-3.7:=[llvm_targets_BPF(+)]
+       ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT#v}
+
+pkg_pretend() {
+       local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
+               ~BPF_JIT ~BPF_EVENTS ~DEBUG_INFO ~FUNCTION_TRACER ~KALLSYMS_ALL"
+
+       check_extra_config
+}
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DREVISION=${PV%%_*}
+       )
+
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       python_fix_shebang "${ED}"
+}